Sage 9.0.10: "Right now, PostCSS does nothing"


I started working on a new project yesterday and starting getting this notice while using yarn start:

You did not set any plugins, parser, or stringifier. Right now, PostCSS does nothing. Pick plugins for your case on and use them in postcss.config.js.

I just confirmed that this also occurs on a completely fresh install. Have you noticed the same and is there a fix?


Yes, I’ve the same here

1 Like

I’ve also gotten compilation errors when I wanted to import fonts into my styles. This worked without any issues in previous versions of Sage.

Hence I’ve now downgraded to 9.0.9. Unfortunately 9.0.10 seems quite buggy.

Some updated dependencies may cause these issues, I have to look into it.

1 Like

Likely caused by incompatible versions of file-loader and resolve-url-loader.

More details and comments in PR #2572.

1 Like

This bug could be causes this issue too?

1 Like

You have likely experienced two different problems. I’d recommend for you to keep using 9.0.9 to eliminate several issues causing confusion at the same time.


How did you downgraded sage?

I technically didn’t downgrade but installed 9.0.9 in a separate theme folder and migrated the asset files I had created.

You can install a specific version like that:

composer create-project roots/sage:9.0.9 replace-with-theme-name


I have just noticed exactly the same problem, was getting errors Module build failed: ModuleNotFoundError: Module not found: Error: Can't resolve './images/wall.png' in... when running yarn build but installing 9.0.9 and moving all files to that resolved issue. Not sure what’s going wrong with 9.0.10?

You may want to try this sage 9 pull request that updates a lot of dependencies and webpack to v4, which should fix these issues:

It probably still doesn’t work as it should. In production build it’s ok but dev on watche … Still the same as it was. …