Roots Discourse

Sage 9.0.9 Yarn build:production fails with Error: Cannot find module '../5/CheckObjectCoercible'

My yarn build works great, my yarn build: production though throws this:
Any ideas?

$ webpack --env.production --progress --config resources/assets/build/webpack.config.js
module.js:550
throw err;
^

Error: Cannot find module '../5/CheckObjectCoercible'
at Function.Module._resolveFilename (module.js:548:15)
at Function.Module._load (module.js:475:25)
at Module.require (module.js:597:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/Users/mikey/Local Sites/crosses- 
music/app/bedrock/web/app/themes/sage/node_modules/es- 
abstract/2020/RequireObjectCoercible.js:3:18)
at Module._compile (module.js:653:30)
at Object.Module._extensions..js (module.js:664:10)
at Module.load (module.js:566:32)
at tryModuleLoad (module.js:506:12)
at Function.Module._load (module.js:498:3)
error Command failed with exit code 1.

Looks like your modules are broken, try with re-installing YARN by yarn install --ignore-scripts && yarn build:production.

Also this PR may help, it fixes some sage 9 issues (and updates dependencies, webpack to v4):

that worked… ish… now my regular “yarn build” gives this error:
Failed to load plugin ‘import’ declared in ‘.eslintrc.js’: Cannot find module ‘…/5/CheckObjectCoercible’

I tried installing that plugin, no dice. Same error. I ended up downgrading to 9.0.9, works like a charm

You get this error when trying out the PR?