Sage 9 dist directory not being updated on Staging Deploy


#1

I am using the default (uncommented-out) deploy-hooks/build-before.yml, and the deploy (including build) runs successfully (according to stdout), but the dist directory that’s getting loaded off the staging server isn’t being updated.

Sage 9.0.0
Trellis master (1.0.0-rc2?)

I’m probably missing a step.


#2

How are you verifying this?


#3

Thanks, Ben. Verification

  1. noticing by looking at it in various browsers, hard-reloaded. The javascript and styles don’t seem to be matching to what’s here, locally.

  2. Ssh into the server to make sure dist directory is current.

  • drwxr-xr-x 2 web www-data 4096 Apr 12 13:33 styles
    date
    Thu Apr 12 13:36:16 UTC 2018
  • dist/assets.json matches files:
  • "scripts/main.js": "scripts/main_bea28d9e.js"
  • dist/scripts/main_bea28d9e.js
  1. Confirm some style declaration that is here locally is absent
  • ed styles/main_bea28d9e.css
    /sub-navigation
    ?
  1. Insure that i am deploying the branch I think I am and that it’s up to date
  • git status
    on branch development
    up to date
  • group_vars/staging/wordpress_sites.yml#branch: development
  1. Confirm current points to the release I just deployed
  • development@68b8d00 deployed as release 20180412133234
  • current -> /srv/www/intensity.club/releases/20180412133234

Confounding. (Also confirmed ip address correct.)


#4

Progress. It’s only in browsersync that I’m seeing the changes I am making.

The local dist production matches the remote!

So why is what’s being rendered in browsersync not being compiled when I run yarn run build:production?

When I ran yarn run start again I see my changes at example.test.

Then I deploy and they are gone again.

UPDATE: I noticed that when running yarn run build:production the same files were being “generated”. I made a change to a file and ran again and then new files were generated. Still not sure what exactly I had done wrong.

But it’s working now.