Sage ( Install and activation

hello,

SO i am having an issue with installing sage 9 :frowning:

My system setup is a s follows:

OS: windows 7
Vangrant box: latest version
node: latest version
yarn: latest version
composer: latest version
php: 7.1.8

I have done this 4 times now with no success. the first time it was the roots-example-theme.com project cloned directly. Although that worked I was not able to run yarn and update any assets. Reading on the forum it seemed that it may have been due an incomplete install.

I then followed steps (same as what will be listed below) to start fresh with a new theme and give it some customisation too. So i followed: https://roots.io/trellis/docs/installing-trellis/ to install trellis and bedrock THEN i followed: https://roots.io/sage/docs/theme-installation/ to install the theme. It didn’t give me a prompt to customise the meta or framework etc as I’m on windows and it gives the TTY error. I can however go to vendor\bin\sage meta to configure it.

Once that’s done i did vagrant up and waited.

I did the above steps 2 times and each time although the box was provisioned and wordpress was installed it had the following 2 issues:

  1. unable to access the wordpress admin with admin:admin even though i haven’t changed anything in the vault.yml
  2. the twenty seventeen them was shown. Inspecting the source code it was calling /wp/wp-content/themes and not what I would have assumed should have been: /app/themes/MYTHEME/

So before posting here i thought i would do a totally fresh install again. this time using all defaults and making no changes to rule out any potential issues. The steps I followed are:

  1. followed this first: https://roots.io/trellis/docs/installing-trellis/

mkdir example.com && cd example.com
git clone --depth=1 https://github.com/roots/trellis.git && rm -rf trellis/.git
git clone --depth=1 https://github.com/roots/bedrock.git site && rm -rf site/.git

I didn’t do any other changes i.e. from here: https://roots.io/trellis/docs/wordpress-sites/ kept it default all the way.

  1. then i followed this: https://roots.io/sage/docs/theme-installation/ which seems to be the same as: https://github.com/roots/sage/ readme.

cd site/web/app/themes
composer create-project roots/sage mythemename

NO option came up for customising so I ran only

vendor\bin\sage meta
and configured theme meta I did not do the other 2.

I then ran yarn in theme folder

  1. once all above done I then ran vagrant up from trellis folder and waited.

Same result. box provisions, wordpress works BUT:

  1. cannot login to wp admin with admin:admin
  2. default twenty seventeen them being used from wp-content folder.

Can someone please tell me what I am missing here? struggling to see where I am going wrong…

Twentyseventeen being activate on a new Trellis project is the expected behavior. You created your new theme but you didn’t activate it, so, just like any new WordPress site it’ll use the default which is Twentyseventeen.

It’s more odd that you can’t log in with admin:admin. You’re able to access the site at your-dev-domain.test ?

Yup i can access it via example.test i can see the site and theme ia twenty seventeeen.

Cannot access the admin even though i haven’t changed the username or pass…

Can you try changing the admin user’s password?

  1. in your trellis directory type vagrant ssh, then type cd /srv/www/example.test/current/
  2. type wp user update admin --user_pass="admin"

Thankyou @MWDelaney That seems to have done the trick! I can know access wp admin and have chosen roots as the theme.

Wonder why its not allowing me to access on a fresh install. Something doesnt seem right…

Lastly. Should the sage theme be with no styling at all? Or is it because i wasnt given the preset options on setup? Shpuld i go to vendor\bin\sage presets amd choose my option then run yarn && yarn build? Will that then give me some styling?

Sage ships with little to no styling. Running yarn && yarn build will install Bootstrap as the default dependency and build the basic styles (which pretty much just turns the links purple and that’s it). Everything else is on you to build.

Thank you for confirming. Thought i was going mad for a moment :wink: