Sage Mac m1 php composer dependencies require 8.1 you are using 8.0

I can’t activate sage theme without this error and I don’t have a clue how to update this. Using Mac M1 with parallels vm

Are you using Acorn? If so, what version? And what’s in your theme’s composer.json?
Your local php version is 8.0?

I had exactly same problem. This is todo with your local php version being higher.
You simply need to use brew install php@8.0 then brew unlink php@8.1 after that brew link php@8.0

Yeah or bump the php version constraint to 8.1 in the composer.json?

I was using the acorn version from the install docs on Sage with composer. As of now the only way for me to get this working is installing the plugin version from GitHub. How would I change the php version constraint to 8.1 in the composer.json?

Try changing this line:



and run:

rm -rf vendor && rm composer.lock && composer install

Fatal error : Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 8.1.0”. You are running 8.0.19

this is the error that brought me here… to recap: trellis up from parallels arm64 box, downloaded sage to the themes folder cd to sage composer require acorn then Fatal error… Im starting from scratch for the 20th time at this point will report back… Thanks for the help!

My Solution: group_vars/all/main.yml >change php version from 8.0 to 8.1 …trellis up.
wp throws depreciate error until you activate the sage theme

Any news on this? Still getting the error.

Im using
Mac M1
Current Acorn (v2.1) installed with Composer in Combination with the current bedrock build.
Running Local with PHP 8.0

Modifying the php Version in composer.json and reinstall the packages did not work.

Have you tried using the platform option in the config?

1 Like

I had the same issue and downgrading both my local php version and acorn (v3x to v2.1) solved the problem.