Roots Discourse

Sage trying to load jquery 1.12.1

Hi,

I have a new instalation of sage over VVV

I’m seeing a very strange error on the console:

Failed to load resource: the server responded with a status of 404 (OK)
main.js
https://ajax.googleapis.com/ajax/libs/jquery/1.12.1/jquery.min.js

The url does not exist.

I have another project that is loading
https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js
Without any problem

The strange thing is that the project with the error is working correctly and correctly includes a jquery from:
/wp-includes/js/jquery/jquery.js

I also can see, in both projects, a jQuery v2 on dist. It doesn’t seem to be a requirement from the other libraries I’m installing with bower and I’m not requiring it nominally at all.

I understood that roots switched back to jQuery v1 so I don’t know what that v2 does here.

Also it doesn’t seem to get used at all.

  1. Does anyone have this 1.12.1 problem?
  2. Where is the version of the jQuery sage uses specified?
  3. Should I be worried about having so many jQueries?

Thanks!

Sage does nothing as far as jQuery versions goes.

Are you also using Soil?

Hi @benword,

Yes, I am.

My require from composer.json looks like this:

"require": {
    "php": ">=5.4.0",
    "composer/installers": "~1.0",
    "roots/soil": "3.6.2",
    "wpackagist-plugin/wp-migrate-db": "^0.7.2",
    "jjgrainger/wp-custom-post-type-class": "^1.4",
    "wpackagist-plugin/advanced-custom-fields": "^4.4",
    "wpackagist-plugin/post-type-switcher": "^1.5",
    "wpackagist-plugin/posts-to-posts": "^1.6",
    "wpackagist-plugin/advanced-excerpt": "^4.2.3",
    "roots/wp-password-bcrypt": "^1.0",
    "wpackagist-plugin/kau-boys-backend-localization": "^2.1"
  },

I guess the wrong jquery maybe comes from WordPress (using VVV an the nightly build of WP so maybe it comes from that).
I moved everything to the stable of WordPress on VVV and I don’t see the error any more.

This is my first project with VVV and I assumed I should use http://src.WordPress-develop.dev because it has “develop” on it. Maybe not XD

Thanks!

Soil tries to load the version of jQuery that core uses from the Google CDN, so if an upcoming WP ver is using one that doesn’t exist on the Google CDN then we’re going to run into issues

1 Like

if jQuery is not working (404 missing request to remote server) go to app/setup.php and disable this line. seems relevant to add now - you won’t get the benefit of the CDN but it should work normally.

add_theme_support('soil-jquery-cdn');

Sorry I did not close that. It was a problem with wordpress and jquery versions. Updating wordpress solved that.

Thanks to all!