Roots Discourse

Satispress - Invalid Credentials

I know this is not a Roots issue but there is limited support or information to be found about the issue I am having.

It would be awesome if someone else can attempt to run composer update with Satispress dependencies to see if they’re encountering the same problem.

I’ve been using Satispress as a central package server for many projects for a while now with zero issues after initially getting setup. I use the same API Key (user) and Password (satispress) for all the different projects. I haven’t had a reason to change any of the credentials, composer or auth files and all of a sudden, when I attempt to run composer update I get the following error:

[Composer\Downloader\TransportException]
Invalid credentials for ‘https://satispress.mydomain.com/satispress/packages.json’, aborting.

I’ve opened up several different projects and tried to update composer and it returns the same error. I have no idea what could be causing this. Can someone else give it a try and see if they experience the same results?

In order to not waste anyone’s time with this, it turns out that composer update fails when I have installed any of the WPML.org plugins into Satispress. Once I delete them, it will update again.

2 Likes

@joshb are you doing any sort of CI/CD with a build server/service with this setup? I’m trying to figure out the best way of not storing the credentials directly in the repository of the projects I’m using SatisPress with and allowing this setup to work in an automated way. Each CI/CD platform has a way to store secret keys but I’m not sure how these will play well with the authentication requirements of SatisPress. Thanks!

Is anyone familiar with how Satispress recognizes new releases? I thought it would be as simple as creating a new release for a private plugin in github and then our satispress installation would see that and provide that option. That doesn’t appear to be the case.

Why not get composer to install it from GitHub?
I use SatisPress for the plugins I pay for if they don’t already allow installation by Composer. I just set them to auto update on my satispress site and then I log in every 6 months or so to check on it!

This topic was automatically closed after 42 days. New replies are no longer allowed.