Setting up Amazon SES


#1

Hey!

I’ve verified my domain with Amazon SES, created smtp credentials that I put into my mail.yml and vault.yml. Then I went ahead and setup an actual mail account for the address I want to use and verified that address with Amazon SES. At this point I thought I was ready to go so I tried asking my site to reset password but I didn’t receive any reset mail, and no error message either.

What else do I need to do?


#2

Your credentials are most likely incorrect


#3

Are you familiar with SES specifically? I understand that you cannot provide support for services beyond Roots, but I’m having a hard time figuring this out.

mail_smtp_server: email-smtp.us-west-2.amazonaws.com:587 (fetched from SMTP settings at SES console)
mail_admin: info@mydomain.tld
mail_hostname: mydomain.tld
mail_user: AKIAJ (..and a bunch of other random letters received at SMTP credentials setup)
mail_password: "{{ vault_mail_password }}" (in vault.yml I put the passwd received on SMTP credentials setup).

Is it because I use port 587?
Nothing in error.log on the server either (if that’s relevant for the mail service…)


#4

My ssmtp.conf looks like this

root=info@mydomain.tld
AuthMethod=LOGIN
FromLineOverride=Yes
UseTLS=Yes
UseSTARTTLS=Yes
hostname=mydomain.tld
mailhub=email-smtp.us-west-2.amazonaws.com:587
AuthUser=redacted
AuthPass=redacted

#5

Is it on your local / development environment and getting caught by Mailhog?


#6

Thanks for taking time to help out ian! But unfortunately this is on my production site so mailhog should not be an issue!


#7

Ace! I’ll be doing this in a couple of weeks. Last time I used SES a few years ago, it was hellish to set up.


#9

Just checked /var/log/mail.log and it contains repeated messages like this

Mar 20 08:30:01 ip-x-x-x-x sSMTP[2408]: Creating SSL connection to host
Mar 20 08:30:01 ip-x-x-x-x sSMTP[2408]: SSL connection using RSA_AES_128_CBC_SHA1
Mar 20 08:30:02 ip-x-x-x-x sSMTP[2408]: 554 Transaction failed: Missing final '@domain'

Edit: Seems to be related with Cron job don't send emals with Amazon SES


#10

FromLineOverride=No seems to do the trick.


#11

Just a quick follow up. I had WooCommerce installed and it had an email from dev configured that caused the mails to fail to send. So when I was trying to reset password, WooCommerce intercepted and used it’s email settings rather than the usual WP settings.

My bad!

If you’re experiencing problems with ssmtp, be sure to set Debug=Yes in ssmtp.conf and then check syslog for any errors.