Settings for local Vagrant SSH connection with Sequel Pro

Hi guys, I’ve read through the discourse topics as best I can for similar issues and have tried most of them with no luck. I am trying to connect to my local MySQL database with Sequel Pro but am getting a permission denied error. I’m not sure if my settings are correct.

Here is my wordpress_sites file

- canonical: relaxva.local
local_path: …/site # path targeting local Bedrock site directory (relative to Ansible root)
enabled: false
enabled: false
provider: self-signed
enabled: false

Am I doing something really obvious wrong?

It seems like you’re trying to SSH to your local host (, that’s not going to work. Need to SSH to your Vagrant box.

You can get the IP Address like this:

Hey Kalen, I’m using the settings as laid out here

Well this is interesting. I didn’t understand the info in the coderwall link (I’m still a newbie to this stuff) but I found (I think the IP of the Vagrant box inside vagrant.default.yml so I tried that and got the below.

This seems to be telling me it’s found the DB but won’t let the SSH host connect for some reason. Note that the roots documentation suggests the SSH host should be example**.test** but I’m assuming (I know, dangerous) that this is on the understanding that a local dev environment would use this domain. I am using .local and not .test (as in my wordpress_sites file) hence why I have changed it or am I wrong here?

Anyone have any further thoughts?

Whoops, my bad, it’s been quite a few years since I used Sequel Pro. Should be correct in that you used the local URL in SSH Host.

Back to square one then!

@richt The settings in your original screenshot look good except…

SSH Port. Will you run vagrant ssh-config | grep Port in your trellis directory? Add that port to the “SSH Port” field at bottom of Sequel Pro window.

Username. Also try changing to relaxva_co_uk then attempt the connection again.

Hiya, I delved a little into the .env file and noticed that was set to relaxva_co_uk so I changed that in Sequel Pro and voila!

Thank you for your help and thank you for all the time and effort you’ve put into the Roots project. I’m new to serious WP development and it’s certainly been a steep learning curve but I’m super excited about making this my default workflow.