Setup local WordPress Skeleton on MAMP to work like in Composer with WordPress screencast

Hi all,

I’ve watched and followed through the screencast Composer with WordPress and it seems like my local setup on MAMP can’t achieve as what shown in the s’cast.

Upon digging into the problem, I notice that my MAMP setup is a little different that some of the configuration of examples/solutions that I found from Googling.

I have my MAMP to document root at /Users/ajmalafif/Sites/localhost with some folders (work with few CMSes like drupal, joomla etc.)

drwxr-xr-x   3 ajmalafif  staff    102 Oct 19 14:07 angular
drwxr-xr-x   5 ajmalafif  staff    170 Jan  2  2013 drupal
drwxr-xr-x  15 ajmalafif  staff    510 Nov 28 00:13 experiments
drwxr-xr-x   5 ajmalafif  staff    170 Aug 16  2012 joomla
drwxr-xr-x   4 ajmalafif  staff    136 Oct 20 23:17 magento
drwxr-xr-x   4 ajmalafif  staff    136 Dec 15 23:44 pagoda
drwxr-xr-x   5 ajmalafif  staff    170 Dec 15 22:10 php
drwxr-xr-x  55 ajmalafif  staff   1870 Jun 13  2013 sendy
drwxr-xr-x   8 ajmalafif  staff    272 Nov  5 16:26 shopify
drwxr-xr-x  33 ajmalafif  staff   1122 Dec 15 22:13 wp

I managed to get almost everything to work except the part of Roots load its assets files. By default (upon Chrome Inspection), the assets files that are loaded gave me 404s at this URL:


and if I hardcoded it into omnibox, the file should be inside


Any pointers or guides on how to at least to debug this? Thanks!

Found a solution!

Inside local-config.php:

This is a sample local-config.php file
In it, you *must* include the four main database defines

You may include other settings here that you only want enabled on your local development checkouts

define( 'DB_NAME', '' );
define( 'DB_USER', '' );
define( 'DB_PASSWORD', '' );
define( 'DB_HOST', 'localhost' ); // Probably 'localhost'

At the bottom of the file, Include this line to point it to your local MAMP directory. In my case it was;

define( 'WP_CONTENT_URL', 'http://' . $_SERVER['HTTP_HOST'] . '/pagoda/boiler/content' );