Site name same as staging subdomain

When I run ansible-playbook server.yml -e env=staging for the first time, I get:

TASK [wordpress-setup : Create database of sites] ******************************
System info:
  Ansible; Linux
  Trellis at "Fix #569 - Only skip subdomains for non-www domains"
'dict object' has no attribute u''
fatal: []: FAILED! => {"failed": true}

RUNNING HANDLER [fail2ban : restart fail2ban] **********************************
changed: []
	to retry, use: --limit @server.retry

PLAY RECAP *********************************************************************           : ok=78   changed=6    unreachable=0    failed=1   

This is my vault.yml part


And this is my wordpress_sites.yml


Note that both site name and staging subdomain are equal.

And those files are group_vars/staging/vault.yml and group_vars/staging/wordpress_sites.yml?

Yes staging folder, everything else as stock, changed the domains in development and staging folders. Development vagrants up ok, but staging is giving me problems.
So based on notice I got in the Ansible process, I supposed it could be due to same domain == site name/key in dictionary, but I don’t understand Ansible that well.

Did you finally solved the issue @Ivan_Svaljek ? I’ve got the same problem…

What I did is: bought a domain to differentiate staging host from site name, replaced all instances of in group_vars.
Now site name is and staging host is and it seems to go ok.
But now that I think of it, it also seems to have been some instance of host name or site name in some stray trellis file, so I suggest you do a grep (or grepwin) through your hole trellis folder for those two names.

But it seems subdomains should be reserved for staging mode, I guess we’re not supposed to have the site name equal staging host name (but this is my guess).

Thanks for your impressions on this @Ivan_Svaljek . I will take this into account and hopefully I’ll be able to solve the issue.