Roots Discourse

Soil error - Cannot declare class Roots\Soil\Options

Receive error:

error on line 9 of file wp-content/plugins/soil-main/src/Options.php - Cannot declare class Roots\Soil\Options, because the name is already in use

Error happens only when Shield Security plugin is activated. Happens on any theme when soil is activated and theme support added.

Any ideas on how to fix?

1 Like

@Elwood-P EDIT: Looking into this, thanks for the report!

1 Like

We’re pushing an update out shortly that will make our autoloader more strict and fix this :+1:

This issue has been resolved in the latest release, Soil 4.0.5 :white_check_mark:

1 Like

Thanks for reporting this @Elwood-P! :pray:t3:

1 Like

Amazing, thank you guys. Huge respect to the work you do on these projects. :pray:

1 Like

Confirmed v4.0.5 updates solves this for me.

I’m sure you’re on it but just to say soil.php needs the version number bumping.

This topic was automatically closed after 42 days. New replies are no longer allowed.