Roots Discourse

SOLVED: Deployed without errors but blade templates arn't updateing on production

ansible
trellis
blade
sage9

#1

I’ve provisioned the DO droplet and deployed with no errors.
Then did some local development:

  • edit header.blade.php
  • created a nav.scss in styles/components
  • added nav.scss to main.scss

Then deployed again
ansible-playbook server.yml -e env=production
No errors

But when I look at the production server, the markup hasn’t updated.


#2

What version of Trellis?

Did you commit your changes to the git repo?

Did you commit your changes to the git repo on the same branch that your deploy is using for production?

Have you SSH’d into the server and checked to make sure that the files from the latest deploy match what you’re looking for?


#3

Hey benword,
Thanks for the reply, it’s fairly new build, so I think it’s trellis 1.0.1.
How would I find the version?

Yes commited and pushed to master. And yes master is the same branch that is for the deploy.

I ssh’d in, but I’m not sure of the file path. Is it the same for every DO droplet? Could you tell me the file path?

Thanks again for your help


#4

Okay I’ve figured where to find the file through ssh.
For future reference when you first log in, you need to cd ../ to the root dir. Then look in srv/www which should contain a folder with your website’s name. Change dir into you site’s folder.

I’m not sure here, but I think the folder named “current” should have all the files that are live.
There’s also a releases directory. Which in my case has quite a few folders in it because I’ve tried to deploy a lot.

None this really helps much, because the files in my current folder still are not what I have in my repo.

I’m starting to feel like I’m talking to myself here guys… any help would be great.


#5

Do other changes to the site deploy successfully? If you add a plug-in with composer, commit, push, and deploy, do you see that plugin on the production site?

Is it just theme changes that aren’t working?

Check WordPress’s appearance/themes and confirm there aren’t two entries for your theme there. If there are, try activating the other one.


#6

Hi MWDelaney,

I’ve just figured it out, I was trying to deploy with ansible-playbook server.yml -e env=production
But what I should have been doing is ./bin/deploy.sh production website.com

Sorry for my ignorance, I’m just a front end who want’s to be a full stack. Slowly but surly.
Thanks for trying to help tho.


#7

You need to deploy with the deploy.yml playbook - server.yml is for provisioning (totally missed this in your OP :smiley:)

Thanks for following up