[Solved] Roots and Woocommerce Stripe Plugin errors

I am having an problem with my new Roots theme under development and the woocommerce Stripe payment plugin.

A javascript error pops up on the screen when submitting the payment, however there are no javascript errors when inspecting the source.

I tested the same set-up with the twenty eleven theme with no errors.

So far i have tried to disable the scripts.js file with no luck, tried to downgrade the jquery with no luck. The only plugins i’m using are woocommerce and the woocommerce stripe plugin.

Has anyone else had this problem? Or any advice? Hopefully I was clear enough.

thanks in advance.

Maybe that plugin isn’t compatible with the latest jQuery? Try adding jQuery Migrate into the mix and see if that works. If it doesn’t, you can always just disable the Google CDN jQuery in lib/config.php to load the default jQuery from WordPress.

1 Like

I used the solution proposed in this comment in the past, not sure if it is the same issue you are running into (also have not looked into the issue to see why it happened), but it might be worth checking out.

1 Like

I had quick look at the code and would suggest disabling the rewrites (if you still have them) and the root relative urls.

Hey guys,

Thanks for all the suggestions. I got it working in two different ways:

  1. I used the solution @chriscarr mentioned and it worked perfectly.

  2. I also got it working by switching to Woocommerce version 2.1-bleeding from their github project. Once I switched it over, it miraculously started working again.

Going forward, I’m going to use option #1 with the release version of woocommerce.

Thanks again!