sSMTP role not sending e-mails while smtp plugin works well

Hi There,

A few days ago I tried to set up the sSMTP mail role of trellis because I have an external mail server that’s handling all email traffic of my client.
I immediately noticed that the sSMTP role did not send mails. It’s of course possible that it triggers, and tries to send an e-mail but my external mail server doesn’t work.

After that I tried to install the WP Mail SMTP plugin by WPForms. When I entered the same email settings as I did for the sSMTP role of trellis, it did actually send e-mail. I was happy by then because I just wanted to stick with the plugin that worked.

However, after a few days of development I noticed that the WP Mail SMTP plugin didn’t go along that well with another plugin for WordPress that manages packing slips. If the packing slip plugin was active, the WP Mail SMTP plugin didn’t work anymore. So my best guess is to get the sSMTP role of trellis working to get the mail functionality from the core instead of from a 3rd party plugin. Right?

Does anyone of you know where to find logs or something that the sSMTP role outputs? I have no clue how to debug this thing.
Or maybe someone knows what the issue is with the WP Mail SMTP plugin in combination with the packing slip plugin?

I’m waiting for the golden answer!


Can someone close this post. I resolved this issue by changing my mail server “send as” to be the same as the mail username.