Ssmtp send as

How do I go about changing the sender address?

Right now it’s sending all email from the server as deploy@domain.tld.

We have FromLineOverride set so you should be able to overwrite it through WordPress? Although maybe that isn’t working since I assume there’s something different in Admin > General options > Email address?

Yes sir, it is different there.

@swalkinshaw Figured it out. For whatever reason, in ssmtp.conf the lines read as


Changing these to Yes fixed it.

What’s odd however, is that in the default tasks in - it’s already Yes.

Food for thought.

1 Like

Wow, I think this is Ansible behaviour to treat all those values as booleans. Pretty sure the fix is to quote the Yes values as strings. I’ll do the fix.

1 Like

Cool, cheers.

20 chars.