Stage Switcher 2.0.0 local dev failure

With an ‘out-of-the-box’ Trellis & Bedrock installation from today (2016-04-08), I am unable to get wp-stage-switcher 2.0.0 running locally. No other plugins are running.

The PHP Notices show up on every page within /wp-admin and are:

  • Notice: Use of undefined constant ENVIRONMENTS - assumed 'ENVIRONMENTS' in /srv/www/ on line 50
  • Notice: unserialize(): Error at offset 0 of 12 bytes in /srv/www/ on line 50
  • Warning: Invalid argument supplied for foreach() in /srv/www/ on line 53

After a manual plug-in installation, tried to install via composer and verified the correct dependencies ended up in vendor/. Just for the heck of it, I tried manual install of PHP-curl and restarting PHP + nginx and vagrant provision.

This is all local; no staging yet. OSX 10.11.4, Vagrant 1.8.1 on VMware Fusion, Ansible, Composer 1.0.0

Did you define and set the ENVIRONMENTS constant as the README says?

Thanks…I do now. :innocent:

I misread the docs, so when it said “If you use Bedrock, WP_ENV is already defined in the config,” I assumed it was both ENVIRONMENTS and WP_ENV.