Sudoing as the admin user - password not working

I’ve read through the similar topics, especially this: Admin password not working

Still no luck in being able to sudo as the admin user in production. Deploys are working fine though.

My group_vars/production/vault.yml has:

# Documentation:
  - name: "{{ admin_user }}"
    password: [[REDACTED]]
> ssh admin@server
> sudo su -
[sudo] password for admin:
(pasted password)
Sorry, try again.

security.yml vars:

sshd_permit_root_login: false
sshd_password_authentication: false

My admin user is in the sudo group, which I guess it must be for deploys to be working.

Any suggestions on what to try next?

1 Like

I just tried this myself on a server.

ssh admin@server and then sudo su -. The password from the vault user worked.

Not exactly sure what else could be going on. If you really need root access though, most server providers have a way to access a web console as root.


I was just trying to look at the logs. Couldn’t access the web user either. :-/ I’m sure I must have done something boneheaded at some point, but I’m at a loss at where to look.

I’m leary of trying to change the password for fear of screwing up the server and my ability to deploy. Guess maybe I’ll create a new environment from scratch, and try it there first.

Thanks for the sanity check, Scott. Appreciate it!

Just closing the loop here. I blew away the machine and created a new droplet from scratch and the problem did not recur.

1 Like