Roots Discourse

Sync Script plugin - media library empty

Hi,
i bought the plugin (Unlimited Sites) and I tried my first sync, from development to staging.

Things that I have done:

  • I created the scripts/ folder and I added the updated sync.sh
  • I updated the site/wp-cli.yml with the alias
  • I installed WP-CLI on my machine followed this https://wp-cli.org/
  • I reprovisioned the development and staging environment, and I deployed everything to the staging.

so then I run this ./sync.sh development staging from my local ‎⁨site/scripts folder and this is the output

✅ Able to connect to development
✅  Able to connect to staging

Success: Exported to 'xxxx_com_staging-2019-12-15-b6b5f43.sql'.
Success: Database reset.
Success: Imported from '-'.
building file list ...
36 files to consider
rsync: connection unexpectedly closed (8 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at /BuildRoot/Library/Caches/com.apple.xbs/Sources/rsync/rsync-52.200.1/rsync/io.c(453) [sender=2.6.9]


🔄  Sync from development to staging complete.

I can see that the db has been updated, I can see the media library has the current amount of objects, but the images (uploads) are not there.

Did I miss a step? do you know what I am possibly doing wrong?
thanks

Hey there! I looked up that rsync error message and it looks like it might have something to do with the uploads directory not yet existing on the remote server? :thinking:

Does the STAGDIR that you defined exist on your staging setup?

Hi @benword, I am pretty sure that there was an upload directory on the remote server, because I was able to upload files from wp-admin.
I will do another test with this, maybe on a new droplet and I will see if it will still happen.

all ok now, there was a mistake on the STAGDIR path.

This topic was automatically closed after 42 days. New replies are no longer allowed.