Roots Discourse

Sync Script - unable to connect to development

When I try to execute sync script from @benword (no matter which direction), I get this error: “Unable to connect to development”

Connection with staging and production works fine.

URLs in ./sync.sh and wp-cli.yml are setup correctly.

local dev setup is up and running without any issues.

vagrant ssh is working fine

Manually transferring database and uploads folder works fine.

Doing wp @development (from where should this be executed?) in scripts-folder returns: " Error: Cannot connect over SSH using provided configuration."

Having this issue on two projects, on the other ones sync script works fine.

Any ideas?

You’ll need to reprovision your VagrantBox with: vagrant reload --provision, then it will work.

hey, thanks a lot for your reply. I’m pretty sure that is something I have already tried. But I will try again and post here if I had success with that.

Not OP but I’m having the same issue and a reprovision did not fix the issue for me. Still getting the error (cannot connect over SSH using provided configuration) except for me I get it when testing @development, staging, AND production. Have configured the aliases and followed instructions… at one point the script was working for this website but I have no idea what might have changed since then besides perhaps MacOS Catalina.

Thanks guys!!

My apologies guys. It was working for me after I reprovisioned but I’m in the same boat. I even tried this WP-CLI --SSH on Windows as well, and it didn’t work either. I’ve tried it on both Catalina and Windows 10 and I’m having the same issue as well. I was hoping to get off WP Migrate DB Pro, but I’ll utilize that until this is resolved.

Thanks for the update! Haha I can be relatively sure I’m not doing something wrong at least :slight_smile:

I ended up nuking WSL and reinstalling. Ben’s solution solved my issue in Windows10. WP-CLI --SSH on Windows I haven’t been able get to the Catalina issue, but I’m going to try with the newest Vagrant @2.2.6 and just copy my group_vars and hosts folder when I get a chance jspn.

For older versions of Trellis, you might need to apply these changes if you’re not seeing them on your setup: