Trellis-cert - certificate import failed

Quick breakdown of recent events.

Had trellis set up and working for long time, last night begun a new repo with latest version of trellis as I wanted to try out Lima. The domains I intend to use on that are the same as my existing trellis install. Copied wordpress_sites over etc.

This morning I turned off the Lima server to get back to work on my existing trellis as I am not ready to switch yet. I saw an SSL issue so I ran: vagrant trellis-cert trust to re-trust all certs, all worked apart from one, the main one I need to work too.

myusername@L00922 trellis % vagrant trellis-cert trust
preview.mydomain.test certificate imported successfully

preview.mydomain.test certificate import failed

The failed one is the main domain of my multisite too. I have re-run the trust command, also re-provisioned too. Having the same issue. When loading the site currently it’s showing:

Secure Connection Failed

An error occurred during a connection to preview.mydomain.test. PR_END_OF_FILE_ERROR


    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the web site owners to inform them of this problem.

Learn more…

I also deleted the cert from keychain and re-ran trust command again too, no luck. Still seeing:

preview.mydomain.test certificate import failed

Sorted, found that issue domain in my hosts file, likely due to my Lima testing. Removed for now so original trellis can continue as it was before. Trellis cert trust worked again.