Trellis CLI throws error when creating new project

Having an issue with Trellis CLI or something related to it. Whenever I try to start a new Trellis project, I get this error:
panic: runtime error: invalid memory address or nil pointer dereference
Context: I started a trellis project on Friday. Today, I ran into an issue getting it up and running. Since I hadn’t started working on it, I destroyed the vm, then removed the project directory. When I tried to create the project from scratch, this error popped up.
To try fixing this, I restarted my mac. I removed trellis cli and reinstalled it. Still no fix. I also ran trellis up on another trellis project on my local machine. It started up fine.
Anyone ever run into this issue before?

Here is the full stack trace.

[signal SIGSEGV: segmentation violation code=0x2 addr=0x0 pc=0x104f69d1c]

goroutine 1 [running]:*Trellis).HostsFromDomain(0x0?, {0x140000221c8?, 0x1400016f750?}, {0x1050922d3, 0xa})
        /home/runner/work/trellis-cli/trellis-cli/trellis/config.go:89 +0xdc{0x1052a26e8?, 0x1400010cb90?}, 0x140001432c0?, {0x140000221c8?, 0x1?})
        /home/runner/work/trellis-cli/trellis-cli/cmd/new.go:281 +0x44*NewCommand).Run(0x1400015de80, {0x140001121a0?, 0x140001499e0?, 0x12c623a88?})
        /home/runner/work/trellis-cli/trellis-cli/cmd/new.go:91 +0x1e8*CLI).Run(0x14000165e00)
        /home/runner/go/pkg/mod/ +0x4cc
        /home/runner/work/trellis-cli/trellis-cli/main.go:222 +0x1d2c