Trellis Deploy Not Pulling Latest Git Version

When doing a deploy, I’ve noticed that my latest changes aren’t going into effect. It’s correctly making a new releases directory, and symlinking it to /current. However, it’s not pulling the latest version of the git repo.

If I ssh into the server, and run a git clone on the exact same repo, I do get the latest version of it. Is there some sort of caching I should know about? It doesn’t make sense.

Strange. I can’t think of any caching.

You could double-check that you have branch set to master, or to whatever branch/tag has the recent updates. You can even set it to the SHA1 of a commit. You could of course double-check that you’ve specified your intended repo.

deploy.yml will only clone project files to the project_source_path if it detects the repo’s files have changed. Later, when it copies files to the new build dir, it will be copying the files most recently cloned to project_source_path. So, if the clone skipped during the current run, it will copy files cloned previously. Under the “Clone project files” task, do you get a “changed” status (i.e., it did clone latest) or an “ok” status (i.e., it didn’t bother cloning because it didn’t see changes)?

Has it worked before with this particular project, but stopped working? Or has it never worked?

1 Like

Thank you for the information @fullyint. Clone Projects Files task does indeed just say ‘ok’.

The only time it worked correctly was the initial time I ran deploy.yml after the initial install. Since then, it’s just been apparently not cloning it. I’m going to try to update to the SHA1 right now, and try that.

After I was able to clone the SHA1 version, I then switched it back to master. I ran into the symlink issue that’s all over these forums, and ended up just adding subtree: site and now everything works. Interesting! But thanks for your help.

I just made a PR with this commented out by default, as it’s very easy to miss, I think everyone’s done it