Roots Discourse

Trellis don't open in host browser

trellis
#1

greeting

i have worked to install trellis+bedrock this last week and everything went smoothly only small warnings
i will address, the problem is the fake local domain I assign don’t work in host browser and give me:-

# This site can’t be reached

**gamemag.test** ’s server IP address could not be found.

* Search Google for [gamemag test](https://www.google.com/search?q=gamemag%20test)

ERR_NAME_NOT_RESOLVED

i followed the instructions on those links :


and for windows :
https://roots.io/getting-started/docs/windows-development-environment-trellis/

i installed wsl ubuntu 18.04

installed:
oracle vm virtual box 6.0.4
vagrant 2.24

throw wsl :-
python 3.6
pip
ansible 2.7.0

my system: pc windows 10 pro build 17763 October 2018 Update
here is the changes i made to the following files:

W:\projects\gamemag\trellis\group_vars\development\worpress_sites.yml:

wordpress_sites:
  gamemag.space:
    site_hosts:
      - canonical: gamemag.test
        # redirects:
        #   - www.gamemag.test
    local_path: ../site # path targeting local Bedrock site directory (relative to Ansible root)
    admin_email: admin@gamemag.test
    multisite:
      enabled: false
    ssl:
      enabled: false
      provider: self-signed
    cache:
      enabled: false

W:\projects\gamemag\trellis\group_vars\development\vault.yml

vault_mysql_root_password: "yougiy12"

# Variables to accompany `group_vars/development/wordpress_sites.yml`
# Note: the site name (`example.com`) must match up with the site name in the above file.
vault_wordpress_sites:
  gamemag.space:
    admin_password: "yougiy12"
    env:
      db_password: "yougiy12"

W:\projects\gamemag\trellis\vagrant.default.yml

vagrant_ip: '192.168.87.77'
vagrant_cpus: 1
vagrant_memory: 4096 # in MB
vagrant_box: 'bento/ubuntu-18.04'
vagrant_box_version: '>= 201807.12.0'
vagrant_ansible_version: '2.7.0'
vagrant_skip_galaxy: false
vagrant_mount_type: 'nfs'

vagrant_install_plugins: true
vagrant_plugins:
  - name: vagrant-bindfs
  - name: vagrant-hostmanager

# Array of synced folders:
# - local_path: .
#   destination: /path/on/vm
#   create: false
#   type: nfs
#   bindfs: true
#   mount_options: []
#   bindfs_options: {}
# See https://www.vagrantup.com/docs/synced-folders/basic_usage.html#mount_options
vagrant_synced_folders: []

i can vagrant ssh to trellis server
i tried many soulution like ufw enabling:
https://www.digitalocean.com/community/tutorials/how-to-set-up-a-firewall-with-ufw-on-ubuntu-16-04

i tried make static ip in /etc/network/interfaces

i tried this

#The loop back network  interface
auto lo
iface lo inet loopback

#the primary network interface

auto eth1
iface eth1 inet static
address 192.168.50.7

netmask 255.255.255.0

network 192.168.50.0

broadcast 192.168.50.255

gateway 192.168.50.1

dns-nameservers 192.168.50.3

then i remove project vagrant destroy and build it up again, i even remove VirtualBox and vagrant and delete all there related files in the users directory even wsl and reinstall every thing again
and nothing changed .

vagrant reload --provision
after every solution, i try

and tried this solution here

the poster here although his problem turn out to be in the tools he installed but he provide solution i tired in my vm like this :
W:\projects\gamemag\trellis\group_vars\development\main.yml

acme_tiny_challenges_directory: "{{ www_root }}/letsencrypt"
env: development
ferm_enabled: false
mysql_root_password: "{{ vault_mysql_root_password }}" # Define this variable in group_vars/development/vault.yml
web_user: vagrant


# Should the firewall be enabled?
ferm_enabled: true

ferm_input_group_list:
  - type: "dport_accept"
    dport: ["http", "https", "3000", "5001" , ""]
    filename: "nginx_accept"

Here is 2 warnings i get throw installation or provisioning

TASK [geerlingguy.daemonize : Download daemonize archive.] *********************
 [WARNING]: Module remote_tmp /root/.ansible/tmp did not exist and was created
with a mode of 0700, this may cause issues when running as another user. To
avoid this, create the remote_tmp dir with the correct permissions manually
 dependency geerlingguy.daemonize from role mailhog differs from
already installed version (1.2.1), skipping

here is output throw installation ‘i uploaded file’

W:\projects\gamemag\trellis
λ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Importing base box 'bento/ubuntu-18.04'...
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'bento/ubuntu-18.04' version '201812.27.0' is up to date...
==> default: Setting the name of the VM: gamemag.test
==> default: Pruning invalid NFS exports.
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
    default: Adapter 2: hostonly
==> default: Forwarding ports...
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
    default: Warning: Connection reset. Retrying...
    default: Warning: Connection aborted. Retrying...
    default: Warning: Remote connection disconnect. Retrying...
    default:
    default: Vagrant insecure key detected. Vagrant will automatically replace
    default: this with a newly generated keypair for better security.
    default:
    default: Inserting generated public key within guest...
    default: Removing insecure key from the guest if it's present...
    default: Key inserted! Disconnecting and reconnecting using new SSH key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
    default: The guest additions on this VM do not match the installed version of
    default: VirtualBox! In most cases this is fine, but in rare cases it can
    default: prevent things such as shared folders from working properly. If you see
    default: shared folder errors, please make sure the guest additions within the
    default: virtual machine match the version of VirtualBox you have installed on
    default: your host and reload your VM.
    default:
    default: Guest Additions Version: 5.2.22
    default: VirtualBox Version: 6.0
==> default: Setting hostname...
==> default: Configuring and enabling network interfaces...
==> default: Exporting NFS shared folders...
==> default: Preparing to edit nfs mounting file.
[NFS] Status: halted
[NFS] Start: started
==> default: Mounting NFS shared folders...
==> default: Mounting shared folders...
    default: /vagrant => W:/projects/gamemag/trellis
==> default: Checking for bindfs in VM...
    default: Package manager detected: apt-get
    default: Fuse kernel module is installed
    default: Fuse kernel module is loaded
==> default: Bindfs seems to not be installed on the virtual machine, installing now
    default: Bindfs 1.13.7 is installed
==> default: Machine is ready to use bindfs!
==> default: Creating bind mounts after synced_folders...
    default: /vagrant-nfs-gamemag.com => /srv/www/gamemag.com/current
    default: /ansible-nfs => /home/vagrant/trellis
    default: /home/vagrant/trellis/bin => /home/vagrant/trellis/bin
==> default: [vagrant-hostmanager:guests] Updating hosts file on active guest virtual machines...
==> default: [vagrant-hostmanager:host] Updating hosts file on your workstation (password may be required)...
==> default: Running provisioner: ansible_local...
    default: Installing Ansible...
    default: Installing pip... (for Ansible installation)
    default: Running ansible-galaxy...
- downloading role 'composer', owned by geerlingguy
- downloading role from https://github.com/geerlingguy/ansible-role-composer/archive/1.7.0.tar.gz
- extracting composer to /home/vagrant/trellis/vendor/roles/composer
- composer (1.7.0) was installed successfully
- downloading role 'ntp', owned by geerlingguy
- downloading role from https://github.com/geerlingguy/ansible-role-ntp/archive/1.6.0.tar.gz
- extracting ntp to /home/vagrant/trellis/vendor/roles/ntp
- ntp (1.6.0) was installed successfully
- downloading role 'logrotate', owned by nickhammond
- downloading role from https://github.com/nickhammond/ansible-logrotate/archive/v0.0.5.tar.gz
- extracting logrotate to /home/vagrant/trellis/vendor/roles/logrotate
- logrotate (v0.0.5) was installed successfully
- downloading role 'swapfile', owned by oefenweb
- downloading role from https://github.com/Oefenweb/ansible-swapfile/archive/v2.0.6.tar.gz
- extracting swapfile to /home/vagrant/trellis/vendor/roles/swapfile
- swapfile (v2.0.6) was installed successfully
- downloading role 'mailhog', owned by geerlingguy
- downloading role from https://github.com/geerlingguy/ansible-role-mailhog/archive/2.1.3.tar.gz
- extracting mailhog to /home/vagrant/trellis/vendor/roles/mailhog
- mailhog (2.1.3) was installed successfully
- adding dependency: geerlingguy.daemonize
- downloading role 'daemonize', owned by geerlingguy
- downloading role from https://github.com/geerlingguy/ansible-role-daemonize/archive/1.2.1.tar.gz
- extracting geerlingguy.daemonize to /home/vagrant/trellis/vendor/roles/geerlingguy.daemonize
- geerlingguy.daemonize (1.2.1) was installed successfully
    default: Running ansible-playbook...

PLAY [Set ansible_python_interpreter] ******************************************

TASK [python_interpreter : Get Ubuntu release] *********************************
ok: [default]

TASK [python_interpreter : Set ansible_python_interpreter for Ubuntu 18.04 Bionic] ***
ok: [default]

PLAY [WordPress Server: Install LEMP Stack with PHP 7.3 and MariaDB MySQL] *****

TASK [Gathering Facts] *********************************************************
ok: [default]

TASK [common : Load wordpress_sites.yml vars into <env>_sites vars] ************
skipping: [default] => (item=development)

TASK [common : Fail if there are duplicate site keys within host's wordpress_sites] ***

TASK [common : Validate wordpress_sites] ***************************************
skipping: [default]

TASK [common : Validate format of site_hosts] **********************************
skipping: [default] => (item=gamemag.com)

TASK [common : Verify dict format for apt package component variables] *********
skipping: [default]

TASK [common : Verify dict format for apt package combined variables] **********
skipping: [default]

TASK [common : Validate Ubuntu version] ****************************************
skipping: [default]

TASK [common : Check whether passlib is needed] ********************************
skipping: [default]

TASK [common : Retrieve local SSH client's settings per host] ******************
ok: [default]

TASK [common : Validate compatible settings between SSH client and server] *****
ok: [default] => {
    "changed": false,
    "msg": "All assertions passed"
}

TASK [common : Checking essentials] ********************************************
ok: [default] => (item=build-essential)
changed: [default] => (item=libnss-myhostname)
changed: [default] => (item=unzip)
changed: [default] => (item=python3-mysqldb)
ok: [default] => (item=python)
ok: [default] => (item=git)
ok: [default] => (item=dbus)
ok: [default] => (item=curl)
ok: [default] => (item=python3-software-properties)
changed: [default] => (item=python3-pycurl)

TASK [common : Validate timezone variable] *************************************
ok: [default]

TASK [common : Explain timezone error] *****************************************
skipping: [default]

TASK [common : Add myhostname to nsswitch.conf to ensure resolvable hostname] ***
ok: [default]

TASK [common : Generate SSH key for vagrant user] ******************************
changed: [default]

TASK [common : Retrieve SSH client IP] *****************************************
skipping: [default]

TASK [fail2ban : ensure fail2ban is installed] *********************************
changed: [default]

TASK [fail2ban : ensure fail2ban is configured] ********************************
changed: [default] => (item=jail.local)
changed: [default] => (item=fail2ban.local)

TASK [fail2ban : ensure fail2ban starts on a fresh reboot] *********************
ok: [default]

TASK [ferm : ensure ferm status is in debconf] *********************************
changed: [default]

TASK [ferm : ensure ferm is installed] *****************************************
changed: [default]

TASK [ferm : ensure configuration directories exist] ***************************
changed: [default] => (item=/etc/ferm/ferm.d)
changed: [default] => (item=/etc/ferm/filter-input.d)

TASK [ferm : ensure firewall is configured] ************************************
changed: [default] => (item=etc/default/ferm)
changed: [default] => (item=etc/ferm/ferm.conf)

TASK [ferm : ensure iptables INPUT rules are removed] **************************
skipping: [default] => (item={u'dport': [u'http', u'https'], u'type': u'dport_accept', u'filename': u'nginx_accept'})
skipping: [default] => (item={u'dport': [u'ssh'], u'type': u'dport_accept', u'saddr': [u'10.0.2.2']})
skipping: [default] => (item={u'dport': [u'ssh'], u'seconds': 300, u'hits': 20, u'type': u'dport_limit'})
skipping: [default] => (item={u'dport': [u'http', u'https', u'3000', u'5001'], u'type': u'dport_accept', u'filename': u'nginx_accept'})

TASK [ferm : ensure iptables INPUT rules are added] ****************************
changed: [default] => (item={u'dport': [u'http', u'https'], u'type': u'dport_accept', u'filename': u'nginx_accept'})
changed: [default] => (item={u'dport': [u'ssh'], u'type': u'dport_accept', u'saddr': [u'10.0.2.2']})
changed: [default] => (item={u'dport': [u'ssh'], u'seconds': 300, u'hits': 20, u'type': u'dport_limit'})
changed: [default] => (item={u'dport': [u'http', u'https', u'3000', u'5001'], u'type': u'dport_accept', u'filename': u'nginx_accept'})

TASK [ferm : ensure iptables rules are enabled] ********************************
skipping: [default]

TASK [ferm : ensure iptables rules are disabled] *******************************
ok: [default]

TASK [ntp : Include OS-specific variables.] ************************************
ok: [default]

TASK [ntp : Ensure NTP-related packages are installed.] ************************
changed: [default]

TASK [ntp : Ensure tzdata package is installed (Linux).] ***********************
ok: [default]

TASK [ntp : include_tasks] *****************************************************
skipping: [default]

TASK [ntp : Set timezone] ******************************************************
ok: [default]

TASK [ntp : Ensure NTP is running and enabled as configured.] ******************
ok: [default]

TASK [ntp : Ensure NTP is stopped and disabled as configured.] *****************
skipping: [default]

TASK [ntp : Generate ntp.conf file] ********************************************
changed: [default]

TASK [sshd : Ensure latest SSH server and client are installed] ****************
changed: [default] => (item=openssh-server)
ok: [default] => (item=openssh-client)

TASK [sshd : Create a secure sshd_config] **************************************
changed: [default]

TASK [sshd : Create a secure ssh_config] ***************************************
changed: [default]

TASK [sshd : Remove Diffie-Hellman moduli of size < 2000] **********************
ok: [default]

TASK [mariadb : Add MariaDB APT key] *******************************************
changed: [default]

TASK [mariadb : Add MariaDB PPA] ***********************************************
changed: [default]

TASK [mariadb : Install MySQL client] ******************************************
changed: [default]

TASK [mariadb : Install MySQL server] ******************************************
changed: [default]

TASK [mariadb : Disable MariaDB binary logging] ********************************
changed: [default]

TASK [mariadb : Set root user password] ****************************************
changed: [default] => (item=default)
changed: [default] => (item=127.0.0.1)
changed: [default] => (item=::1)
changed: [default] => (item=localhost)

TASK [mariadb : Copy .my.cnf file with root password credentials.] *************
changed: [default]

TASK [mariadb : Delete anonymous MySQL server users] ***************************
ok: [default] => (item=localhost)
ok: [default] => (item=default)
ok: [default] => (item=gamemag)

TASK [mariadb : Remove the test database] **************************************
ok: [default]

TASK [geerlingguy.daemonize : Download daemonize archive.] *********************
 [WARNING]: Module remote_tmp /root/.ansible/tmp did not exist and was created
with a mode of 0700, this may cause issues when running as another user. To
avoid this, create the remote_tmp dir with the correct permissions manually

changed: [default]

TASK [geerlingguy.daemonize : Expand daemonize archive.] ***********************
changed: [default]

TASK [geerlingguy.daemonize : Check if daemonize is installed.] ****************
ok: [default]

TASK [geerlingguy.daemonize : Build daemonize.] ********************************
changed: [default] => (item=./configure --prefix=/usr)
changed: [default] => (item=make)
changed: [default] => (item=make install)

TASK [mailhog : Ensure mailhog install directory exists.] **********************
changed: [default]

TASK [mailhog : Download MailHog and mhsendmail binaries.] *********************
changed: [default] => (item={u'url': u'https://github.com/mailhog/MailHog/releases/download/v0.2.1/MailHog_linux_amd64', u'dest': u'/opt/mailhog/mailhog'})
changed: [default] => (item={u'url': u'https://github.com/mailhog/mhsendmail/releases/download/v0.2.0/mhsendmail_linux_amd64', u'dest': u'/opt/mailhog/mhsendmail'})

TASK [mailhog : Copy mailhog init script into place.] **************************
skipping: [default]

TASK [mailhog : Copy mailhog systemd unit file into place (for systemd systems).] ***
changed: [default]

TASK [mailhog : Ensure mailhog is enabled and will start on boot.] *************
changed: [default]

TASK [php : Add PHP 7.3 PPA] ***************************************************
changed: [default]

TASK [php : Install PHP 7.3] ***************************************************
changed: [default] => (item=php7.3-fpm)
changed: [default] => (item=php7.3-dev)
ok: [default] => (item=php7.3-xml)
changed: [default] => (item=php7.3-curl)
changed: [default] => (item=php7.3-mysql)
changed: [default] => (item=php7.3-gd)
changed: [default] => (item=php7.3-xmlrpc)
ok: [default] => (item=php7.3-opcache)
ok: [default] => (item=php7.3-cli)
ok: [default] => (item=php7.3-common)
changed: [default] => (item=php7.3-mbstring)
changed: [default] => (item=php7.3-zip)

TASK [php : Start php7.3-fpm service] ******************************************
ok: [default]

TASK [php : Check for existing php7.2-fpm service] *****************************
ok: [default]

TASK [php : Stop php7.2-fpm service if it exists] ******************************
skipping: [default]

TASK [php : PHP configuration file] ********************************************
changed: [default]

TASK [xdebug : Install Xdebug] *************************************************
changed: [default]

TASK [xdebug : Template the Xdebug configuration file] *************************
changed: [default]

TASK [xdebug : Ensure 20-xdebug.ini is present] ********************************
ok: [default]

TASK [xdebug : Disable Xdebug] *************************************************
skipping: [default]

TASK [xdebug : Disable Xdebug CLI] *********************************************
changed: [default]

TASK [memcached : Install memcached] *******************************************
changed: [default] => (item=memcached)
changed: [default] => (item=php-memcached)

TASK [memcached : Copy the client configuration file] **************************
changed: [default]

TASK [memcached : Set the max open file descriptors] ***************************
changed: [default]

TASK [memcached : Start the memcached service] *********************************
ok: [default]

TASK [nginx : Add Nginx PPA] ***************************************************
changed: [default]

TASK [nginx : Install Nginx] ***************************************************
changed: [default]

TASK [nginx : Create SSL directory] ********************************************
changed: [default]

TASK [nginx : Generate strong unique Diffie-Hellman group.] ********************
skipping: [default]

TASK [nginx : Copy h5bp configs] ***********************************************
changed: [default]

TASK [nginx : Create nginx.conf] ***********************************************
changed: [default]

TASK [nginx : Disable default server] ******************************************
changed: [default]

TASK [nginx : Enable Nginx to start on boot] ***********************************
ok: [default]

TASK [logrotate : nickhammond.logrotate | Install logrotate] *******************
ok: [default]

TASK [logrotate : nickhammond.logrotate | Setup logrotate.d scripts] ***********
changed: [default] => (item={u'path': u'/srv/www/**/logs/*.log', u'options': [u'weekly', u'maxsize 50M', u'missingok', u'rotate 8', u'compress', u'delaycompress', u'notifempty', u'create 0640 vagrant www-data', u'sharedscripts'], u'name': u'wordpress-sites', u'scripts': {u'postrotate': u'service nginx rotate', u'prerotate': u'if [ -d /etc/logrotate.d/httpd-prerotate ]; then \\\n      run-parts /etc/logrotate.d/httpd-prerotate; \\\n    fi \\\n'}})

TASK [composer : Set php_executable variable to a default if not defined.] *****
ok: [default]

TASK [composer : Check if Composer is installed.] ******************************
ok: [default]

TASK [composer : Download Composer installer.] *********************************
changed: [default]

TASK [composer : Run Composer installer.] **************************************
changed: [default]

TASK [composer : Move Composer into globally-accessible location.] *************
changed: [default]

TASK [composer : Update Composer to latest version (if configured).] ***********
ok: [default]

TASK [composer : Ensure composer directory exists.] ****************************
ok: [default]

TASK [composer : Add GitHub OAuth token for Composer (if configured).] *********
skipping: [default]

TASK [composer : include_tasks] ************************************************
included: /home/vagrant/trellis/vendor/roles/composer/tasks/global-require.yml for default

TASK [composer : Install configured globally-required packages.] ***************
changed: [default] => (item={u'name': u'hirak/prestissimo'})

TASK [composer : Add composer_home_path bin directory to global $PATH.] ********
changed: [default]

TASK [composer : include_tasks] ************************************************
skipping: [default]

TASK [wp-cli : Ensure gpg2 is installed] ***************************************
changed: [default]

TASK [wp-cli : Download WP-CLI Phar] *******************************************
changed: [default]

TASK [wp-cli : Download WP-CLI Phar Signature] *********************************
changed: [default]

TASK [wp-cli : Copy WP-CLI release team public key] ****************************
changed: [default]

TASK [wp-cli : Verify WP-CLI Phar Signature] ***********************************
ok: [default]

TASK [wp-cli : Install WP-CLI] *************************************************
changed: [default]

TASK [wp-cli : Retrieve WP-CLI tab completions] ********************************
changed: [default]

TASK [wp-cli : Install WP-CLI tab completions] *********************************
changed: [default]

TASK [wp-cli : Install WP-CLI packages] ****************************************

TASK [wordpress-setup : Create databases for sites] ****************************
changed: [default] => (item=gamemag.com)

TASK [wordpress-setup : Create/assign database user to db and grant permissions] ***
changed: [default] => (item=gamemag.com)

TASK [wordpress-setup : Generate self-signed certificates] *********************
skipping: [default] => (item=gamemag.com)
skipping: [default] => (item=no_default)

TASK [wordpress-setup : Download client cert] **********************************
skipping: [default] => (item=gamemag.com)

TASK [wordpress-setup : Create web root] ***************************************
changed: [default]

TASK [wordpress-setup : Create logs folder of sites] ***************************
changed: [default] => (item=gamemag.com)

TASK [wordpress-setup : Create WordPress php-fpm configuration file] ***********
changed: [default]

TASK [wordpress-setup : Disable default PHP-FPM pool] **************************
changed: [default]

TASK [wordpress-setup : Build list of Nginx includes templates] ****************
ok: [default -> localhost]

TASK [wordpress-setup : Warn about deprecated Nginx includes directory] ********
skipping: [default]

TASK [wordpress-setup : Create includes.d directories] *************************

TASK [wordpress-setup : Template files out to includes.d] **********************

TASK [wordpress-setup : Retrieve list of existing files in includes.d] *********
ok: [default]

TASK [wordpress-setup : Remove unmanaged files from includes.d] ****************

TASK [wordpress-setup : Copy SSL cert] *****************************************
skipping: [default] => (item=gamemag.com)

TASK [wordpress-setup : Copy SSL key] ******************************************
skipping: [default] => (item=gamemag.com)

TASK [wordpress-setup : disable temporary challenge sites] *********************
ok: [default] => (item=gamemag.com)

TASK [wordpress-setup : Create Nginx available sites] **************************
changed: [default] => (item={u'src': u'no-default.conf.j2'})
skipping: [default] => (item={u'src': u'ssl.no-default.conf.j2', u'enabled': False})

TASK [wordpress-setup : Enable or disable Nginx sites] *************************
changed: [default] => (item={u'src': u'no-default.conf.j2'})
ok: [default] => (item={u'src': u'ssl.no-default.conf.j2', u'enabled': False})
 [WARNING]: The src option requires state to be 'link' or 'hard'.  This will
become an error in Ansible 2.10


TASK [wordpress-setup : Create Nginx conf for challenges location] *************
changed: [default]

TASK [wordpress-setup : Create WordPress configuration for Nginx] **************
changed: [default] => (item=gamemag.com)

TASK [wordpress-setup : Enable WordPress site] *********************************
changed: [default] => (item=gamemag.com)

TASK [wordpress-setup : Setup WP system cron] **********************************
changed: [default] => (item=gamemag.com)

TASK [wordpress-setup : Setup WP Multisite system cron] ************************
ok: [default] => (item=gamemag.com)

TASK [wordpress-install : Create web root of sites] ****************************
ok: [default] => (item=gamemag.com)

TASK [wordpress-install : Create shared folder of sites] ***********************
changed: [default] => (item=gamemag.com)

TASK [wordpress-install : Change site owner to user] ***************************
changed: [default] => (item=gamemag.com)

TASK [wordpress-install : Create .env file] ************************************
changed: [default] => (item=gamemag.com)

TASK [wordpress-install : Copy .env file into web root] ************************
changed: [default] => (item=gamemag.com)

TASK [wordpress-install : Add known_hosts] *************************************
changed: [default] => (item=github.com ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEAq2A7hRGmdnm9tUDbO9IDSwBK6TbQa+PXYPCPy6rbTrTtw7PHkccKrpp0yVhp5HdEIcKr6pLlVDBfOLX9QUsyCOV0wzfjIJNlGEYsdlLJizHhbn2mUjvSAHQqZETYP81eFzLQNnPHt4EVVUh7VfDESU84KezmD5QlWpXLmvU31/yMf+Se8xhHTvKSCZIFImWwoG6mbUoWf9nzpIoaSjB+weqqUUmpaaasXVal72J+UX2B+2RPW3RcT0eOzQgqlJL3RKrTJvdsjE3JEAvGq3lGHSZXy28G3skua2SmVi/w4yCE6gbODqnTWlg7+wC604ydGXA8VJiS5ap43JXiUFFAaQ==)
changed: [default] => (item=bitbucket.org ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEAubiN81eDcafrgMeLzaFPsw2kNvEcqTKl/VqLat/MaB33pZy0y3rJZtnqwR2qOOvbwKZYKiEO1O6VqNEBxKvJJelCq0dTXWT5pbO2gDXC6h6QDXCaHo6pOHGPUy+YBaGQRGuSusMEASYiWunYN0vCAI8QaXnWMXNMdFP3jHAJH0eDsoiGnLPBlBp4TNm6rYI74nMzgz3B9IikW4WVK+dc8KZJZWYjAuORU3jc1c/NPskD2ASinf8v3xnfXeukU0sJ5N6m5E8VLjObPEO+mN2t/FZTMZLiFqPWc/ALSqnMnnhwrNi2rbfg/rd/IpL8Le3pSBne8+seeFVBoGqzHM9yXw==)
changed: [default] => (item=gitlab.com ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIAfuCHKVTjquxvt6CM6tdG4SLp1Btn/nOeHHE5UOzRdf)
changed: [default] => (item=gitlab.com ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCsj2bNKTBSpIYDEGk9KxsGh3mySTRgMtXL583qmBpzeQ+jqCMRgBqB98u3z++J1sKlXHWfM9dyhSevkMwSbhoR8XIq/U0tCNyokEi/ueaBMCvbcTHhO7FcwzY92WK4Yt0aGROY5qX2UKSeOvuP4D6TPqKF1onrSzH9bx9XUf2lEdWT/ia1NEKjunUqu1xOB/StKDHMoX4/OKyIzuS0q/T1zOATthvasJFoPrAjkohTyaDUz2LN5JoH839hViyEG82yB+MjcFV5MU3N1l1QL3cVUCh93xSaua1N85qivl+siMkPGbO5xR/En4iEY6K2XPASUEMaieWVNTRCtJ4S8H+9)

TASK [wordpress-install : Setup packagist.com authentication] ******************
skipping: [default] => (item=None)
skipping: [default]

TASK [wordpress-install : Install Dependencies with Composer] ******************
ok: [default] => (item=gamemag.com)

TASK [wordpress-install : Install WP] ******************************************
changed: [default] => (item=gamemag.com)

TASK [wordpress-install : Setup Permalink Structure] ***************************
changed: [default] => (item=gamemag.com)

TASK [wordpress-install : Update WP Multisite Home URL] ************************
skipping: [default] => (item=gamemag.com)

RUNNING HANDLER [common : restart memcached] ***********************************
changed: [default]

RUNNING HANDLER [common : reload php-fpm] **************************************
changed: [default]

RUNNING HANDLER [common : reload nginx] ****************************************
changed: [default]

RUNNING HANDLER [common : perform nginx reload] ********************************
changed: [default]

RUNNING HANDLER [fail2ban : restart fail2ban] **********************************
changed: [default]

RUNNING HANDLER [ferm : restart ferm] ******************************************
skipping: [default]

RUNNING HANDLER [ntp : restart ntp] ********************************************
changed: [default]

RUNNING HANDLER [sshd : restart ssh] *******************************************
changed: [default]

RUNNING HANDLER [mariadb : restart mysql server] *******************************
changed: [default]

PLAY RECAP *********************************************************************
default                    : ok=118  changed=83   unreachable=0    failed=0

so any help is appreciated

0 Likes

#2

Does your Windows hosts file contain

192.168.87.77 gamemag.test

?

0 Likes

#3

yeb it does contain this was a step of one of the solutions i tried

0 Likes

#4

Can you access your site if you visit 192.168.87.77 directly?

0 Likes

#5

nope i tried many times

0 Likes