Roots Discourse

Trellis error issues

Hi all. Hope you’re all doing OK. Just wondering if anyone can help if possible.

I’m still a bit new working with Trellis, Bedrock and Sage so forgive me if this is an obvious issue to fix.

I’ve got a few projects which have been all good but I have just started a new local project with Trellis and I keep getting the error message below when I run vagrant up:

The conditional check 'ansible_distribution_version is version('18.04', '<')'
failed. The error was: Version comparison: 'ansible_distribution_version' is
undefined

The error appears to have been in '/Users/davehallett/sites/domainnamehere.com/
trellis/roles/common/tasks/main.yml': line 67, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

I have found this thread - Fresh trellis install - error on vagrant up but not having any luck.

When I run vagrant ssh there is no trellis to be seen.

I then have just tried to run another local project I’ve was working on a week or so ago, and Trellis works fine but when I run yarn start on the Sage theme I now get a 403 Forbidden nginx error!

I’m using:
macOS Big Sure v 11.0.01
Ansible 2.7.2
Vagrant 2.2.13

Can anyone help in any way, please?

Hi Dave,

I haven’t made any progress since the thread you link to. I’m still running Catalina and figured I’d look at it again once I update everything.

Cheers

This topic was automatically closed after 42 days. New replies are no longer allowed.