Trellis fails when installing PIP?

I’ve recently formatted an older MacBook Pro which is now running Big Sur 11.5.1.
My iMac is running all of my tools and projects fine on Big Sur 11.1

Attempting to get an old project up and running on the laptop, I receive the following error:

==> default: Running provisioner: ansible_local...
    default: Installing Ansible...
    default: Installing pip... (for Ansible installation)
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

curl | sudo python

Stdout from the command:

ERROR: This script does not work on Python 2.7 The minimum supported Python version is 3.6. Please use instead.

Stderr from the command:

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 1892k  100 1892k    0     0  7008k      0 --:--:-- --:--:-- --:--:-- 7035k

I am running:
Vagrant 2.2.1

I’ve come across another similar but closed topic here. I don’t understand the fix mentioned.

I installed Python 3.6 and then I received a different error so I reverted back based on that error and what I found on the roots forum.

Anyone have any ideas? TY

Perhaps it is failing at installing PIP?

I found this:

I updated that line in my vagrantfile, ran vagrant box update and then attempted to vagrant up again but still receive the same error above.

Lastly, I updated the vagrantfile with the suggestion in the error output:

ERROR: This script does not work on Python 2.7 The minimum supported Python version is 3.6. Please use instead.

ansible.pip_install_cmd = 'curl | sudo python'
ansible.pip_install_cmd = 'curl | sudo python'

No luck here as well. Produces same error.

I thought maybe something was corrupt on my fresh install of Big Sur so I formatted and reinstalled it. Then continued to get all the packages installed again.

Attempting to run this command:

sudo apt-get install python-pip


sudo: apt-get: command not found

Attempting to run this command:

sudo easy_install pip


SyntaxError: invalid syntax


locate apt-get


WARNING: The locate database (/var/db/locate.database) does not exist.
To create the database, run the following command:

  sudo launchctl load -w /System/Library/LaunchDaemons/

Please be aware that the database can take some time to generate; once
the database has been created, this message will no longer appear.

This topic was automatically closed after 42 days. New replies are no longer allowed.