Trellis - Malformed output discovered from systemd list-unit-files: accounts- daemon.service

Hey all,

Getting the following error when starting a fresh Trellis box in development:

TASK [ntp : Populate service facts.] *******************************************
System info:
Ansible 2.8.0; Vagrant 2.2.14; Linux
Trellis version (per changelog): "Validate that `letsencrypt_contact_emails` is a list
Malformed output discovered from systemd list-unit-files: accounts-
daemon.service                enabled         enabled
fatal: [default]: FAILED! => {"changed": false}

Tried entering an email like as follows in trellis/group_vars/all/main.yml like I normally do. Also tried with a 2nd fresh install without adding these lines.


Got it working as normal by reverting galaxy.yml to what is was a few days ago before this commit -

Is there something I am doing wrong or do the dependencies need looking at?


1 Like

You could try reverting that version bump for the ntp galaxy role. However, it’s a known bug on that role:

Using Ansible. 2.9.8 and higher will fix it.

I’ll have to see what the proper fix on the Trellis side of things is. It’s either using the older role version or bumping our Ansible requirements.


Thanks @swalkinshaw , that solved it. Much appreciated :grinning:

I’m getting the same error but on Ansible 2.10. Do I need to be on Ansible 2.9?

TASK [wordpress-install : Install Dependencies with Composer] ******************
System info:
  Ansible 2.10.3; Vagrant 2.2.3; Darwin
  Trellis version (per changelog): "Validate that `letsencrypt_contact_emails` is a list"

I think you need to reverse this version bump.

Hello, I’m getting the same error(disclaimer: I’m brand new to trellis and Ansible). Where can I set the Ansible version? So that I may use 2.9.8 or higher. I tried editing vagrant_ansible_versionin my vagrant.default.yml file but whenever I run vagrant up I keep getting the same error and Ansible is still loading as the 2.9.6 version. I’ve also tried running vagrant destroy, and vagrant reload in-between version changes but I get the same error.


Check out the docs for installing different Ansible versions with pip -

I wrote my solution on the first message (rolling back galaxy.yml)… Did you try that?

This topic was automatically closed after 42 days. New replies are no longer allowed.