ERROR! Trellis no longer supports Ansible 126.96.36.199.
Please upgrade to Ansible 188.8.131.52 or higher.
Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.
I unfortunately don’t have the time to upgrade/downgrade Trellis on different projects that I’m working on, and just wondering if anybody has faced this issue and came to a quick (maybe even dirty) solution.
With pip it takes a few seconds to change to whichever version of Ansible you need for a given project.
For this current project for which you’ve updated Trellis, you could pip install ansible==184.108.40.206
If running 2.4 doesn’t work for this project (e.g., in case you have customizations that are incompatible with 2.4), hopefully you have this project under version control and can save your latest updates to a separate branch then undo changes.
When you need to work on a project with an older version of Trellis that doesn’t accommodate Ansible 2.4 (i.e., produces errors like these), you could pip install ansible==220.127.116.11
Using pip for changing Ansible version has always been quick and reliable for me, but note the discussion of using Virtualenv to address the issue: