Trellis not creating NGINX sites-available file on vagrant provision

I had to destroy and provision an Ubuntu 20.0 vm. Running into this error:

Destination directory /etc/nginx/sites-available does not exist

I provisioned using the verbose flag, but no additional info was printed.

I am running python3.8 on the Ubuntu VM. I’ve tried running various versions of Ansible. Nothing seems to get me past this error. I even uninstalled Ansible to see if it would let me know what version of Ansible I need to have installed on the VM. It made it to this point again.

I saw this issue, but it looks like the user had ssh’d into the wrong server, so the issue is unrelated.

Any idea where this issue could be coming from? Let me know if there is additional info I need to provide.

Going through my git history to see what changes I’ve made since my last provision. Late into the provision process, I did swap out nginx ppa for Ubunto 20+. I switched out mainline to:

nginx_ppa: "deb {{ ansible_distribution_release }} nginx"

Could this cause the issue?

Just learning, I think, that the ansible version of your machine is what matters. Tried v2.9.6, 2.9.8, 2.9.10. None of these addressed the issue.

Ok solved the issue by ssh’ing into the vm and following these steps.