Trellis provision and deploy commands recently broken - - "ansibile.legacy.setup failed to execute"

Hello everyone,
I’ve been using Trellis and it has been working fine. I was able to provision and deploy multiple servers.

But just now I tried it again on my existing production server, and I’m getting this error:

It seems it has to do with python? But nothing about python should have changed on my PC. Let me know if anybody has some advice, thank you!

This appears to be the same issue (includes fixes):

I added a volume to my digital ocean droplet and after restarting the error seems to have gone away. Thank you!

EDIT: Sorry seems to have been an early call, I got the error after doing the command another two times. I will keep looking into it.

I’m not sure if anyone has a quick method to use the storage block I added to DigitalOcean, I’m assuming it is not using it right now and I’m having a hard time figuring out how to do it.

(I chose the option for DO to auto format it.)

EDIT: Instead of adding a volume, I tried the fool-proof method of resizing the droplet SSD disk. From 20GB to 80GB. However, this didn’t have any effect and I’m getting the same error.


I recreated and reprovisioned the droplet but with a larger SSD disk size. Resizing the droplet didn’t stop the error.

1 Like

Is/was the Droplet using LVM? In that case, multiple steps would be required, including resizing the file system itself, before the system can make use of the additional space.

But besides that, being able to re-create a new instance and quickly re-provision and re-deploy to it is one of the great benefits of using a SCM. Glad you got this fixed.

1 Like