Roots Discourse

Trellis Windows setup

#1

Hi,
first I would like to apologize if this conversation is already somewhere here. I went through all Windows discussions but wasn’t able to finish Trellis installation.

First I was trying official instalation guid but I got stuck. Then I followed this setup https://medium.com/@payter/how-to-setup-trellis-wordpress-installation-on-windows-for-php-storm-easiest-setup-7cafb570559f and I am in point that Vagrant Up runs the server but that is all. Page is returning ERR_CONNECTION_REFUSED.

So I opened Virtual Box and tried to find if nginx is running. But when I try “nginx -v” it returns “nginx: command not found”

Is here somebody with Windows 10 and working Trellis who can send me some set up guid?

Thanks, I am really bad in all of this :smiley:

==> default: Attempting graceful shutdown of VM...
==> default: Checking if box 'bento/ubuntu-18.04' version '201812.27.0' is up to date...
==> default: Clearing any previously set forwarded ports...
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
    default: Adapter 2: hostonly
==> default: Forwarding ports...
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: password
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
    default: The guest additions on this VM do not match the installed version of
    default: VirtualBox! In most cases this is fine, but in rare cases it can
    default: prevent things such as shared folders from working properly. If you see
    default: shared folder errors, please make sure the guest additions within the
    default: virtual machine match the version of VirtualBox you have installed on
    default: your host and reload your VM.
    default:
    default: Guest Additions Version: 5.2.22
    default: VirtualBox Version: 6.0
==> default: Setting hostname...
==> default: Configuring and enabling network interfaces...
==> default: Exporting NFS shared folders...
==> default: Preparing to edit nfs mounting file.
[NFS] Status: running
==> default: Mounting NFS shared folders...
==> default: Mounting shared folders...
    default: /vagrant => C:/Workspace/Projects/trellis/notathome.test/trellis
==> default: Checking for bindfs in VM...
    default: Package manager detected: apt-get
    default: Fuse kernel module is installed
    default: Fuse kernel module is loaded
==> default: Bindfs seems to not be installed on the virtual machine, installing now
    default: Bindfs 1.13.7 is installed
==> default: Machine is ready to use bindfs!
==> default: Creating bind mounts after synced_folders...
    default: /vagrant-nfs-notathome.com => /srv/www/notathome.com/current
    default: /ansible-nfs => /home/vagrant/trellis
    default: /home/vagrant/trellis/bin => /home/vagrant/trellis/bin
==> default: Machine already provisioned. Run `vagrant provision` or use the `--provision`
==> default: flag to force provisioning. Provisioners marked to run always will still run.

==> default: Machine 'default' has a post `vagrant up` message. This is a message
==> default: from the creator of the Vagrantfile, and not from Vagrant itself:
==> default:
==> default: Your Trellis Vagrant box is ready to use!
==> default: * Composer and WP-CLI commands need to be run on the virtual machine
==> default:   for any post-provision modifications.
==> default: * You can SSH into the machine with `vagrant ssh`.
==> default: * Then navigate to your WordPress sites at `/srv/www`
==> default:   or to your Trellis files at `/home/vagrant/trellis`.
0 Likes

#2

Ok, I moved a little bit. I tried to install nginx and my page is now responding with default “Welcome to nginx!” page. Any idea what now?

0 Likes

#3

Please follow the (new!) official Windows docs:

Should be able to find some topics about this if you search

0 Likes

closed #4

This topic was automatically closed after 42 days. New replies are no longer allowed.

0 Likes