Trying to install Sage 10 - manifest.json cannot be found

Hi,

I’m trying to install Sage 10 on my local machine, but I keep getting an error from Acorn. I can’t figure out why this happens. I’m using a clean (the latest) Bedrock install and do the following:

# app/themes or wp-content/themes
$ git clone git@github.com:roots/sage.git your-theme-name
$ cd your-theme-name
$ composer install

The repository clones like it should and Composer installs just fine.

Then, when I activate the theme I get the error.

How can I figure out the cause of this?

Howdy! The manifest can’t be found because you need to run the build first.

  1. yarn
  2. yarn build

PS. Please don’t share screenshots of error messages — it prevents others from finding this topic by searching for the same error, and it also prevents anyone trying to help out from copying and pasting your error

2 Likes

I thought I was missing something. Feeling pretty dumb now. Still getting used to Sage. :slight_smile:

The step is missing from the installation docs, might be a good one to add for people who want to jump into building right away.

I’ll stop posting screenshots and just copy the message, good call.

Thanks, Ben!

2 Likes

same happened to me. but after that im getting another error… i will try to find the solution and then post it here.

I ran into the same issue. Documented yarn commands would be helpful.

Hello
I have same problem , anyone has an idea?
I can’t advance , running yarn it is okey but running yarn build is showing an error

module node os not found