Unable to open requirements.yml on ansible galaxy install for windows


When I am running the command vagrant provision, the windows.sh batch file has the following code to run the ansible galaxy install:

ansible-galaxy install -r ${ANSIBLE_PATH}/requirements.yml -p ${ANSIBLE_PATH}/vendor/roles

however, the terminal responds with the following error:

==> default: [ERROR]: Unable to open /requirements.yml: [Errno 2] No such file or
==> default: directory: ‘/requirements.yml’

I am running vagrant version 1.8.5 and ansible version I have tried upgrading both, destroying the vagrant box and running vagrant up from scratch but the same error occurs.

Any help would be much appreciated.

Since you’re on Windows it’d be best to update to the latest Trellis in order to work off of https://github.com/roots/trellis/pull/690

1 Like

Thanks Ben. I think I may be already working from the latest version, but just to be doubly sure I’ll configure & work from this version.

Hi Ben,

Thanks, I tried the latest and it worked. The version I was using was 0.9.8 but it looks like the latest commit made resolved this issue 4 days ago as there was a direct made for ansible for windows users.

Although, all developers should make sure they are using the latest version I hope this information will be useful to other users!

Kind regards