Unsuccessful AMPPS Localhost Install (Not Found)


I’m sure that I am doing something blatantly wrong, but I cannot seem to get Bedrock working in my local server environment.

I have installed many Wordpress sites successfully on my local machine. Here is what I have attempted with Bedrock:

  • Ran composer (with script) in my localhost folder, installed Bedrock + dependencies
  • Setup empty database called “bedrock” with the user “test”
  • Added “roots” theme to web/app/themes
  • Edited .env to the following:



Navigating to http://localhost/bedrock/wp/wp-admin gives me:

Not Found. The requested URL /wp/wp-admin was not found on this server.

I tried setting my Apache config to look at the bedrock folder as localhost, and updated my .env to remove the “bedrock” directory, and I get the same error.

If I’m hopelessly off-base on this, I apologize :frowning: I did take a look and some threads that seemed similar and I didn’t end up solving my problem. If there are any suggestions that could lead me to success, I would greatly appreciate it.

Thanks so much!

Have you set your Apache vhost to /path/to/site/web/ (or /path/to/site/current/web/ if using Capistrano)?

Ah, didn’t know if this was required yet, as it comes after the step to Access WP Admin.

I’ve never had to do this with AMPPS before, but through Softaculous I Added a New Domain as “web” (will not let me use a trailing slash) which results in the Domain path:


I end up with the same result however (Not Found). This I suppose is likely where I’m going wrong…

I suspect this much is probably beyond the support scope, so I understand if you can’t pursue this any further. If you happen to know any good resources for learning my way however, I would appreciate it :smile:


Thanks for noticing this. Just updated the README to reverse the order of those two steps.

hi Foxaii,

I am facing same problem, can u please give sample for setting vhost on local with xampp ubuntu 14.04.


You’re better off following one of the guides available through search engines.
Just remember that with Bedrock, the web root is the web folder not htdocs.

This topic was automatically closed after 3 hours. New replies are no longer allowed.