Roots Discourse

Updating existing ubuntu 16.04 to Trellis 1.2.0 fails

Hi guys,

An old client just reached out to me because of his expired Let’s Encrypt certificate.
I set their site up with Trellis and Ubuntu 16.04. In order to update the LetsEncrypt endpoint to version 2, I need to update to Trellis 1.2.0 right?

When I try to do that and re-provision locally, I get these errors:

TASK [php : Install PHP 7.3] ***************************************************

System info:

Ansible 2.9.10; Vagrant 2.2.15; Darwin

Trellis 1.2.0: October 11th, 2019

---------------------------------------------------

No package matching 'php7.3-cli' is available

failed: [default] (item=php7.3-cli) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-cli", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-common' is available

failed: [default] (item=php7.3-common) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-common", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-curl' is available

failed: [default] (item=php7.3-curl) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-curl", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-dev' is available

failed: [default] (item=php7.3-dev) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-dev", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-fpm' is available

failed: [default] (item=php7.3-fpm) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-fpm", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-gd' is available

failed: [default] (item=php7.3-gd) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-gd", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-mbstring' is available

failed: [default] (item=php7.3-mbstring) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-mbstring", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-mysql' is available

failed: [default] (item=php7.3-mysql) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-mysql", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-opcache' is available

failed: [default] (item=php7.3-opcache) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-opcache", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-xml' is available

failed: [default] (item=php7.3-xml) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-xml", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-xmlrpc' is available

failed: [default] (item=php7.3-xmlrpc) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-xmlrpc", "value": "present"}}

---------------------------------------------------

No package matching 'php7.3-zip' is available

failed: [default] (item=php7.3-zip) => {"ansible_loop_var": "item", "changed": false, "item": {"key": "php7.3-zip", "value": "present"}}

Is ubuntu 16.04 completely dead?
https://computing.cs.cmu.edu/news/2020/eol-ubuntu-1604
I was hoping that I could avoid creating a new droplet and switching dns etc.
Thanks!