Use trellis on Mac OS Catalina

Hey guys.

Did someone already tried to use trellis with VirtualBox on Mac OS Catalina?

When I tried it last week I got an shared folders error. So I had to go back to Mojave via time machine backup but I really want to update to the beta.

1 Like

In my opinion, upgrading an OS without doing a fresh install is craziness but I feel like I’m one of the rare ones that do it :joy:

This is all we’ve seen about Trellis + Catalina besides this topic so far:

Just chiming in with more detail on this, I’m also receiving NFS errors:

==> default: Exporting NFS shared folders...

NFS is reporting that your exports file is invalid. Vagrant does

this check before making any changes to the file. Please correct

the issues below and execute "vagrant reload":

exports:2: exported dir/fs mismatch: /Users/bj/Sites/ /System/Volumes/Data

exports:3: exported dir/fs mismatch: /Users/bj/Sites/ /System/Volumes/Data

I’ve tried the following as workarounds, with no luck:

  • Upgrade to the latest version of Vagrant
  • Upgrade to the latest version of VirtualBox
  • Upgrade plugins
  • Vagrant reloads / re-provisioning
  • Clean out /etc/hosts
  • Clean out /etc/exports
  • Restart my Mac


vagrant ssh

and checking the server logs, I see

2019/07/09 14:24:42 [error] 2132#2132: *2 rewrite or internal redirection cycle while internally redirecting to "/index.php", client:, server: sitename.test, request: "GET / HTTP/1.1", host: "sitename.test"

It feels as though Kevin Oh’s hunch about filesystem issues is pointing in the right direction. I’d be curious if anyone else has encountered this or been able to make any progress. I can obviously roll back my system if needed, but I’d imagine it’s in the interests of the dev team to have workarounds in place as September approaches.

Thanks in advance for any advice.

Another user on StackOverflow posts:
“The root is sadly no longer just “/…” it is “System/Volumes/Data/…” in this new MacOS but there is a copy of everything on “/” so vagrant is confused on which to use as the root.”

I suspect this is a Vagrant / NFS issue higher up the chain after digging further, and have opened up an issue with the Vagrant team at

It’ll be something to keep an eye on in the coming weeks.

This topic was automatically closed after 42 days. New replies are no longer allowed.