Using yarn install sage, he warns me about unmet peer dependencies

# From your WordPress themes directory, run:
$ composer create-project roots/sage your-theme-name
$ composer create-project roots/sage your-theme-name dev-main
  • they all remind me
yarn install v1.22.19
[1/5] Validating package.json...
[2/5] Resolving packages...
[3/5] Fetching packages...
[4/5] Linking dependencies...
warning " > @roots/sage@6.12.2" has unmet peer dependency "@roots/blade-loader@*".
warning "@roots/sage > @roots/bud-preset-wordpress > @roots/bud-react > @babel/preset-react@7.18.6" has unmet peer dependency "@babel/core@^7.0.0-0".
warning "@roots/sage > @roots/bud-preset-wordpress > @roots/bud-react > @babel/preset-react > @babel/plugin-transform-react-display-name@7.18.6" has unmet peer dependency "@babel/core@^7.0.0-0".
warning "@roots/sage > @roots/bud-preset-wordpress > @roots/bud-react > @babel/preset-react > @babel/plugin-transform-react-jsx@7.18.6" has unmet peer dependency "@babel/core@^7.0.0-0".
warning "@roots/sage > @roots/bud-preset-wordpress > @roots/bud-react > @babel/preset-react > @babel/plugin-transform-react-jsx-development@7.18.6" has unmet peer dependency "@babel/core@^7.0.0-0".
warning "@roots/sage > @roots/bud-preset-wordpress > @roots/bud-react > @babel/preset-react > @babel/plugin-transform-react-pure-annotations@7.18.6" has unmet peer dependency "@babel/core@^7.0.0-0".
warning "@roots/sage > @roots/bud-preset-wordpress > @roots/bud-react > @babel/preset-react > @babel/plugin-transform-react-jsx > @babel/plugin-syntax-jsx@7.18.6" has unmet peer dependency "@babel/core@^7.0.0-0".
warning Workspaces can only be enabled in private projects.
warning Workspaces can only be enabled in private projects.
warning Workspaces can only be enabled in private projects.
warning Workspaces can only be enabled in private projects.
warning Workspaces can only be enabled in private projects.
[5/5] Building fresh packages...
Done in 45.76s.

These warnings will not cause problems when I use them simply, but the problem comes when I use @roots/bud-vue. yarn dev does not have any errors; yarn build has dependency problems.

I pass the query that says the following in stackoverflow
stackoverflow

If I want to solve this problem, do I need to:
yarn add '<unmet peer dependency>'

to add it.

Repeat this until all the warnings have gone when you run yarn install --check-files and the output just looks something like this (no warnings any more):
yarn install --check-files
yarn install v1.22.19
[1/4] 🔍 Resolving packages...
[2/4] 🚚 Fetching packages...
[3/4] 🔗 Linking dependencies...
[4/4] 🔨 Building fresh packages...  
✨Done in 1.54s.

This should be a yarn problem, I don’t know if there is a better solution?

You can ignore those warnings, they should go away after the first time you run yarn

he didn’t go away warning