Vagrant 1.8.5 and Vagrant 2.0.1

Hello, I’m receiving this error message while trying to install a new Trellis instance:

This Vagrant environment has specified that it requires the Vagrant
version to satisfy the following version requirements:

= 2.0.1

You are running Vagrant 1.8.5, which does not satisfy
these requirements. Please change your Vagrant version or update
the Vagrantfile to allow this Vagrant version. However, be warned
that if the Vagrantfile has specified another version, it probably has
good reason to do so, and changing that may cause the environment to
not function properly.

And in effect, while the Install Requirements on the Roots website say Vagrant >= 1.8.5, the Requirements on the Github repo say Vagrant >= 2.0.1.
Can I safely update Vagrant.require_version '>= 2.0.1' to Vagrant.require_version '>= 1.8.5' in the current version of the Vagrantfile? Or can I safely update to Vagrant 2.0.1 without losing the access to my old Trellis local servers?

Yes, this should be fine.

Thank you, it’s safe! - except for some whims of Vagrant 2.0.3 on Windows

edited link