Vagrant - Bedrock-Ansible failed to mount folders in Linux guest

Hello guys . I’ve really benefited from using the Roots theme for a while now and am really excited about applying your workflow to setting up dev and production environments because I’m moving away from shared hosting to VPS.

I’m new to Vagrant and Ansible so its really amazing that you put together a ready made package to get me up and running with them fast but I’ve spent 2 days trying to find out why I can’t get them to work and I’ve hit a wall.

I installed Bedrock with composer then cloned the bedrock-ansible directory.
I then went into bedrock-ansible directory and ran
‘Vagrant up’
It downloads the base box ‘roots/bedrock’ and looks really happy and busy for about 10 minutes.
When I look in the VIrtualBox Gui bedrock-ansible_default_ 1421848627649_34872 is Running happily.

When I look in /etc/hosts it has created a new host:

192.168.50.5 ironing.blog.dev # VAGRANT: de10802c16fe2ce2d899e569a2d62fe9 (default) / 368c9a8b-2142-4ae0-a8fc-ccb34c4050c1

Which looks great because ironing.blog.dev is what I named the site in group_varsdevelopment file.

But when I navigate in the Browser to 192.168.50.5 or ironing.blog.dev i get ‘The web page is not available’ message.

In the terminal at the end of the Vagrant up output I get the following error:

Failed to mount folders in Linux guest. This is usually because
the “vboxsf” file system is not available. Please verify that
the guest additions are properly installed in the guest and
can work properly. The command attempted was:

mount -t vboxsf -o uid=id -u vagrant,gid=getent group vagrant | cut -d: -f3 vagrant /vagrant
mount -t vboxsf -o uid=id -u vagrant,gid=id -g vagrant vagrant /vagrant

The error output from the last command was:

stdin: is not a tty
/sbin/mount.vboxsf: mounting failed with the error: No such device

I’m not sure how you installed Virtualbox, but it sounds like you need to install Guest Additions:

https://www.virtualbox.org/wiki/Downloads

The first list is the actual Virtualbox application, but underneath that is “VirtualBox 4.3.20 Oracle VM VirtualBox Extension Pack”, which you should also install.

Hello kalenjohnson
Thanks so much for this.
I’ve now got the latest version of VirtualBox and and Guest Additions.
This got me a lot further because I got Ansible to run and to do that lovely thing where it scrolls down the screen telling you what it is setting up for you.

Only problem is I still can’t get to see the new virtual WordPress machine in the browser - when I navigate in the Browser to 192.168.50.5 or ironing.blog.dev i still get ‘The web page is not available’ message.

I have no error messages, not even when i run vagrant up --debug
In the task:TASK: [wordpress-sites | WP installed?] ***************************************
all the output was red and at the end it says ‘…ignoring’ in blue text. Does that mean there is a problem? in group_vars/development i left
site_install: true
as it was as I wanted it to install

How do I find php errors? Or any errors that can help me get up and running?

Its working!
How can I buy you a drink? Please let me know.

All i have to do is go to the hostname that i set up in the group_vars/development

I typed :
sudo service network-manager restart
to restart networking so that is would update what it read in /etc/hosts
still cant see anything at
192.168.50.5

  • it gives a message saying
    ’no data received '
    which is weird but I can live with it for now.
1 Like

Glad you got it working, and thanks for coming back and posting your fix :slight_smile: