Vagrant host-manager missing. I think I've tried everything!

I checked the discourse and someone else early last year posted exactly the same thing but had no replies.

I’ve been working on getting Vagrant Share up and running but am stumbling across this annoying error.

vagrant-hostmanager missing, please install the plugin with this command:
vagrant plugin install vagrant-hostmanager

Or install landrush for multisite subdomains:
vagrant plugin install landrush

Running the vagrant plugin install vagrant-hostmanager command as suggested just gives you back the same error. In fact if I do anything related to vagrant plugins such as vagrant plugin list or vagrant plugin update I get the same error.

I’ve tried the same on different environments for different projects and even creating a brand new trellis/bedrock install and got the same error. I’ve also tried uninstalling and reinstalling vagrant and no joy.

It’s also listed as a plugin inside vagrant.default.yml.

Any ideas before I go crazy?

1 Like

I experience the exact same problem. However I don’ t think it’s an issue in trellis, probably Vagrant or the plugin itself.

I’ve tried this, but that didn’t solve it.

I experienced this issue as well. I believe it occurred after I upgraded Vagrant to 2.1.x.

1 Like

Thanks guys. I’ve kinda given up on Vagrant Share for the moment. It appears there are too many issues to overcome, some of which might not even be possible at the moment.

Instead I’m taking a look at using the bedrock-site-protect ansible role to password protect my staging environment.

Thank you manage to solve it by:

Then installing older version:

sudo apt install nfs-common