Vagrant-trellis-cert ruby requirement

I just updated Vagrant to the latest (2.2.8). As usual after an update, I then needed to update or reinstall my Vagrant plugins. All worked fine except vagrant-trellis-cert, which failed with this error:

vagrant-trellis-cert requires Ruby version ~> 2.4.2. The current ruby version is

Unfortunately, I don’t understand where that ruby version is even coming from. My brew-installed ruby is 2.7.1p83, and my system-installed (macOS Catalina 10.15.4) ruby is 2.6.3p62.

Any suggestions or further troubleshooting ideas?

This should probably be an issue on

But @TangRufus hangs out here too. I’m assuming that Ruby version is Vagrant’s bundled Ruby one.

1 Like

Thanks for the repo link. I’ll start an issue there.

Your suspicions must have been correct! I didn’t realize Vagrant bundled Ruby, but I uninstalled and downgraded to the Vagrant version I had previously (2.2.6) and the plugin installed without issue.

Thanks for reporting. This issue has been resolved in
Please try $ vagrant plugin install vagrant-trellis-cert again.
Let me know if you encounter any issues.


This topic was automatically closed after 42 days. New replies are no longer allowed.