Vagrant Up error- The host path of the shared folder is missing

Hey guys, I’m relatively new to Vagrant, absolutely new to Ansibil, so bare with me.

I’m getting an error when I try to run Vagrant Up-

  • The host path of the shared folder is missing: ‘…/’

I know I’m missing something here, so let me run through how I set everything up, and maybe someone can clue me in to what I’m doing wrong.

I’m trying to set up a site called I’m running VirtualBox 4.3.20, Vagrant, Vagrant bindfs, Vagrant Hosts-updater (current versions), and Ansibil 1.8.

  1. I set up a folder called “workflowassassins”, and inside of it created a folder called for my Bedrock installation, and another folder called “bedrock-ansible” for that installation.

  2. Ran composer-install in folder. I did not create a .env file, as bedrock-ansible should take care of it for me.

  3. Added the IP and “” to my etc/hosts file (which, I also am not sure was the correct action, since from my understanding, the hosts-updater plugin should do this automatically upon vagrant up. I assumed this because it says nothing about updating the Vagrantfile in the directions, and upon looking over the Vagrantfile it seems as though there is an if/than statement to take care of this for me if the plugin exists. Once again, if I’m wrong, please, by all means, let me know. )

  4. Edited the group_vars/development file to the following-

    mysql_root_password: devpw
      - site_name:
        local_path: ‘../’ # path targeting local project directory (relative to root/Vagrantfile)
        user: vagrant
        group: www-data
        site_install: true
        site_title: Workflow Assassins
        admin_user: admin
        admin_password: admin
        system_cron: true
          enabled: false
          wp_env: development
          db_name: workflowassassins_dev
          db_user: root
          db_password: root
  5. I ran Vagrant Up, and receivved the error “* The host path of the shared folder is missing: ‘…/’”

So, what am I missing? I was under the assumption from reading the Readme file that I wasn’t supposed to touch the Vagrantfile. I’ve looked over the directions a few times, and the only thing I can see that might be causing this is that in the Bedrock directions it says to set the Nginx path, however, how could I set that if I haven’t yet provisioned Vagrant? If I’m understanding this correctly, the local path is correct, but the host path is not set, but I’m not sure where I would do that.

I could be doing this all wrong, and if that is the case, if someone could let me know where I went wrong, that would be amazing. I tried to put this together from the Readme files, and past Vagrant projects I’ve worked on, but theres still some fuzzy parts in the middle I’m not sure about.

Thanks, P.J.

1 Like

Wow, if anyone is having this same problem… its stupidly simple. It seems that the first character, which is a single quotation mark, was the problem. It was either wrong, or a space ahead… or… something… What I’m sure of is that after 6-7 hours of playing with this today, and retyping the characters after the" '…/ " I decided to finally retype the quotations, periods, and slash, and it worked.

I happened to find another post that referenced this same problem, so it seems I’m not the only one, but even he only said “it was a problem with the first character”. Even my Git hunks don’t show anything has really changed. Maybe it has to do with using Text Edit to modify the file, instead of my normal text editor.

Hopefully in the future I don’t encounter this again.


Sounds like Text Edit added those fancy quotes

1 Like

You are absolutely correct. I reproduced the problem last night. Why are the simplest problems always the ones that take the most time? Oh well, someone is bound to make the same mistake. Hopefully this saves them from having to firmly plant their palm to their face when they realize what the problem was hours later…



I honestly think I have spent more time working out issues just like this than I have on projects hehe, glad you figured it out!

Thanks, this just saved me a lot of time :relaxed: