Vagrant up fails with message "zlib_decode(): data error"


#1

Ansible version: 2.2.0.0
Node version: v7.6.0

When running a vagrant up when no VM is available I receive this error:

TASK [composer : Add GitHub OAuth token for Composer (if configured).] *********
skipping: [default]

TASK [composer : Install configured globally-required packages.] ***************
System info:
Ansible 2.2.0.0; Vagrant 1.8.5; Darwin
Trellis at "Allow for per-project packagist.com authentication"
---------------------------------------------------
Changed current directory to /root/.composer
Do not run Composer as root/super user! See https://getcomposer.org/root for
details
./composer.json has been created
Loading composer repositories with package information
Updating dependencies (including require-dev)

Failed to decode response: zlib_decode(): data error
Retrying with degraded mode, check
https://getcomposer.org/doc/articles/troubleshooting.md#degraded-mode for
more info

Installation failed, deleting ./composer.json.

[ErrorException]
zlib_decode(): data error

require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no- suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with- dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]... failed: [default] (item={u'name': u'hirak/prestissimo'}) => {"changed": true, "cmd": "COMPOSER_HOME=~/.composer /usr/local/bin/composer global require hirak/prestissimo:@stable --no-progress", "delta": "0:00:07.164703", "end": "2017-04-19 19:53:56.969372", "failed": true, "item": {"name": "hirak/prestissimo"}, "rc": 1, "start": "2017-04-19 19:53:49.804669", "stderr": "Changed current directory to /root/.composer\nDo not run Composer as root/super user! See https://getcomposer.org/root for details\n./composer.json has been created\nLoading composer repositories with package information\nUpdating dependencies (including require-dev)\n\nFailed to decode response: zlib_decode(): data error\nRetrying with degraded mode, check https://getcomposer.org/doc/articles/troubleshooting.md#degraded-mode for more info\n\nInstallation failed, deleting ./composer.json.\n\n \n [ErrorException] \n zlib_decode(): data error \n \n\nrequire [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...", "stdout": "", "stdout_lines": [], "warnings": []}

When commenting out:

composer_global_packages:
- { name: hirak/prestissimo }

in file:

repo/ansible/group_vars/all/main.yml

vagrant up works just fine. I also tried running composer clear-cache with no luck as well.

…I left this TASK [composer : Add GitHub OAuth token for Composer (if configured).] above in there since I do NOT have an oauth token set for composer. I’ve read here:

That an oauth token might be required. Haven’t tried that yet.

Any thoughts?


#2

Never seen that error. Oddly enough this thread just came up: Can't find prestissimo composer package

Not even sure Prestissimo is working anyway so you can remove it for now?


#3

I use many small plugins and some speed up would be nice :slight_smile: .


#4

Oh I just meant for @krufe to temporarily remove it from his project if its causing problems since it currently isn’t working.


#5

@swalkinshaw Thanks! I shall do that.