Vagrant Up SSH Error - Windows 10

Hi all,

Sometimes I can navigate successfully after a vagrant up all the way to the the example.dev link in my browser.

But for the most part I’m faced with the below error, and then cannot navigate to the example.dev link in the browser. Although, I can still connect through using vagrant ssh and everything appears to be functioning…

Looks like one of my big problems is vagrant-winnfsd is not starting correctly, so folders aren’t syncing?

However, usually on my first vagrant up I get this error.

I then restart “start-ssh-agent” using cmder and am able to vagrant up, and then connect using vagrant ssh, but most of the time it won’t bring me to example.dev in browser.

Any advice?

I am more familiar using Linux as my host machine, and am a bit fed up with Windows 10 at this point. Looks like it would be more straightforward for me to use Linux at this point.

Thanks!

So am I, still have Linux on my desktop but I recently sold off my MacBook and got a Surface for work. Like it for the most part, but web dev can still be a little tricky.

I was having an issue with SSH key forwarding which I solved with this link: https://www.awmoore.com/2015/10/06/cmder-bash_profile-and-you/ , however, that doesn’t seem like the same issue you’re having. I haven’t seen the same error.

All I can suggest is the normal debugging suggestions to narrow it down. When you’re able to SSH in to the box, is the /vagrant folder there? /vagrant-nfs-yoursite-something ? /srv/www/yoursite.com/current ? If the box looks good but you can’t reach it in your browser, is your hosts file getting updated correctly?

Also to note, I found out that IE Edge DOES NOT work with local sites. I couldn’t figure out why not or how to fix it. It’s like it ignores any changes to your hosts file. It does work with Browsersync though.

1 Like

Thanks for the tip.

I’ll check it out.

I’ve already uninstall Windows and went back to Linux :slight_smile:.