Very initial install step fails - YN0082: │ glob@npm:^10.3.10: No candidates found

Any starting points for investigating this one please?

~/Sites/radicle (main*) » yarn && yarn build                                                                                         
➤ YN0087: Migrated your project to the latest Yarn version 🚀

➤ YN0000: · Yarn 4.0.0-rc.50
➤ YN0000: ┌ Resolution step
➤ YN0082: │ glob@npm:^10.3.10: No candidates found
➤ YN0000: └ Completed in 1s 983ms
➤ YN0000: · Failed with errors in 1s 985ms

My 2 cts here: I had similar issues where a package was not found that was definitely in the repository, and clearing the cache fixed it. Does yarn cache clean fix the issue?

thanks for responding, indeed I have tried this but no luck :slight_smile:

Is the used node version in the required range of the glob (10.3.10) package?:

Are you using a node version manager like nvm or volta?
Does the version reported by node -v fall into the range of the ones required by the package?

Right, yes:

~/sites/radicle » volta list node                                                                                                                                                            
⚡️ Node runtimes in your toolchain:

    v18.17.1 (default)

This means it’s in range right?

node -v is 18.17.1 then probably, correct?

So I just tried installing glob 10.3.10 using npm by myself (in isolation), and it also failed.
It appears that there is an issue with the npm repository caching.
After using npm cache clean --force the issue went away.

Installing glob 10.3.10 using yarn worked out of the box (yarn version 1.22.19).

Thanks, super helpful.

I’ve had some luck by removing yarn.lock then using with these settings, although I’m really not sure, i’m very much experimenting here.

~/sites/radicle » volta pin node                                                                                                                                                          
success: pinned node@20.9.0 (with npm@10.1.0) in package.json
~/sites/radicle » volta pin yarn@1.22.10                                                                                                                                                     
success: pinned yarn@1.22.10 in package.json

So after purging the yarn lockfile and installing with yarn again the issue went away?

Not quite, by pinning those versions of node and yarn it installed successfully.

I did this before seeing your npm cache clean --force comment, so going to start from scratch and try that now

OK so thanks to your help, I believe the issue was the version of Yarn I am using, which was set to yarn@4.0.1. when downgrading this to yarn@1.22.19 the error clears

Is there a version file for the yarn version in radicle? If so, you may want to consider adding a new issue / PR in the radicle repository about this. A yarn version should be locked in that does not have this issue.

I don’t see a locked yarn version anywhere, but others will know more about this than me. i’ll wait to see if anyone responds here, if not will open a PR.