VirtualBox and Host-Only Network - Please Change IP or name of your host only network


Using Trellis on Windows. Everything so far is working very well. Have Vagrant 2.4.1 installed both on Windows as well as WSL2 Ubuntu22.04.

Unless I am confused, I am supposed to run vagrent up in Windows rather than Ubuntu. This appears to work until I get the following error:

PS C:\Users\nero\OneDrive\Desktop\Sites\PGOC\\trellis> vagrant.exe up
Bringing machine ‘default’ up with ‘virtualbox’ provider…
==> default: Checking if box ‘bento/ubuntu-20.04’ version ‘202309.09.0’ is up to date…
==> default: Clearing any previously set network interfaces…
The specified host network collides with a non-hostonly network!
This will cause your specified IP to be inaccessible. Please change
the IP or name of your host only network so that it no longer matches that of
a bridged or non-hostonly network.

Bridged Network Address: ‘’
Host-only Network ‘Realtek USB GbE Family Controller’: ‘’

My local net is
I have tried both changing vagrant.default.yml (but am unsure it is working)

Haven’t worked with YAML. Do I need to run a command to recreate the Vagrantfile?

Also, tried changing the adapter settings on the actual virtual machine inside VM VirtualBox Manager.

Has anyone seen this behavior and able to resolve it?

Any help would be greatly appreciated.


I resolved this issue. From:

Changes the default vagrant_ip from to (note the subtle change from 5056).

A recent change in VirtualBox means that only IP addresses in the range are allowed.

Vagrant is now validating that the IP is within this range as well (hashicorp/vagrant#12564).