Roots Discourse

Warning: Could not find remote branch sage-8 to clone

Hey guys, came across Trellis/Sage/Bedrock and got pretty excited when I saw Yoast is built on Bedrock. Dove into the command lines and have been stuck trying to follow the Roots Example Project since late last night. Everything goes fine up until:

4. Clone Sage: $ git clone --depth=1 --branch sage-8 git@github.com:roots/sage.git site/web/app/themes/sage && rm -rf site/web/app/themes/sage/.git

When I run this, it throws:

Cloning into ‘site/web/app/themes/sage’…
warning: Could not find remote branch sage-8 to clone.
fatal: Remote branch sage-8 not found in upstream origin

I’ve Googled endlessly and tried everything I could find in the forums here, but nothing works. Is it possible the example project is out of date with the release of Sage 9?

Thanks y’all!

That’s correct, it hasn’t been updated for Sage 9 yet. You may have better luck going straight to the docs for Trellis, Bedrock, and Sage.

Thanks for the quick reply, Matt. I’ll do that.

Appreciate you!

Anytime. Welcome aboard!

1 Like