Webpack watch not working


Git cloned the sage repo to my bedrock installation.

  1. used yarn command to install needed node_modules
  2. Modified resourses/assets/config.json to update these two lines:
    “publicPath”: “/app/themes/newtheme”,
    “devUrl”: “http://newtheme.dev”,
  3. In terminal run command yarn run start and this is shown in terminal:
    ⇒ yarn run start
    yarn run v0.23.2
    $ webpack --hide-modules --watch --config resources/assets/build/webpack.config.js

Webpack is watching the files…

[BS] [HTML Injector] Running…
[BS] Proxying: http://newtheme.dev
[BS] Access URLs:

   Local: http://localhost:3000

      UI: http://localhost:3001

UI External:

[BS] Watching files…

Now when I’m modifing anything in resources/assets/, nothing happens. I guess it should check for changes and build new css/js to dist-folder?

My env is macOS el capitan 10.11.6
node v6.10.2
npm v4.5.0

Any idea what I’m doing wrong or missing? Thanks!

yarn run build seem to work nicely…

It doesn’t give feedback all the time. Have you tried to open one of those dev urls that browsersync spit out and actually tried to see if it builds the changes for you? Mine does :+1:

Thanks for the reply, must test that.

But…I would expect to note in terminal that there’s some errors in scss/js I’ve created, now can’t see any of that.

Those errors should be showing up in Webpack’s HMR dialog window in your browser now, if you’re going to the localhost destination browsersync spits out.

Nope…nothing in the browser either :confused:

Maybe I just stick with gulp :smiley:

I had another proxie set up on my machine for an ad blocker and had to create a proxie bypass for the suffix I was using in devUrl to get yarn start to work.