Roots Discourse

Website loads only when using gulp watch, and not by directly navigating to site?

gulp

#1

I’ve been developing a local Wordpress theme based on Sage without an issue until recently (and I’m not sure when this happened) but the website only loads correctly when I use gulp watch.

If I otherwise navigate to the IP and port that the local server is using to get to this site, then nothing between the <body> and </body> tags loads. The rest of the page, such as the <head>, CSS, and JS files all otherwise load fine. The site is exactly the same code-wise when I’m trying to load in either manner.

This is mainly problematic because trying to move my installation to a remote server has resulted in the exact same behavior described above.

I’ve tried normally running gulp to check if anything hasn’t been built, but there are no errors whatsoever. I’ve also tried gulp --production as well with no resolution to this issue.

I’m not seeing anything in PHP error logs, nginx error logs, or MySQL error logs.

Due to this odd problem, I’m not sure how to begin troubleshooting. Has anyone experienced a similar issue before?