Where can I find a complete tutorial for Windows? Trellis + Sage

Hey guys,

Sorry to post in an old thread but its pretty much relevant to what I am doing. I had another post here: Vagrant Up Hang on new install and wasn’t sure whether to post back in there OR in a new one… This one seems to fit what I am having an issue with.

Basically I am trying to get sage up and running on my windows 7 machine. I have a very old roots theme which I used (back in 2013) and fell in love back when grunt was the rage… Moving on and its time for an update BUT I cannot seem to get things off the ground :cry:

Over the last week I have actually pulled my hair out and am about to call quits… hoping one last desperate attempt will show me what I am doing wrong…

SO I had the following installed (will try and be as concise as possible):

windows 7 with SP1 and net 5 framework installed
VB box 5.2.8
vagrant 2.0.2
node 8.10.0
git 2.166.2 (in case i need it)
windows firewall OFF
eset antivirus OFF

When i ran vagrant up from trellis folder seemed like it worked BUT the box was always powered off.

If i then left and came back after a pc restart i could manually power the box on from VB gui (still couldn’t view the site) BUT whenever I did vagrant up from trellis folder it didn’t power on (if I then tried to manually start it the it gives the session error). I checked the hosts file that had the correct lines etc. in it. I was following this guide: https://roots.io/trellis/docs/installing-trellis/ and this one: https://roots.io/trellis/docs/windows/ which doesn’t really make sense as some one has already pointed out.

So for sanity (in case i was doing something wrong) 3rd time round I removed everything and started fresh! Ensured that no files lingered and all folders were deleted. Full strip down and delete…

I used all the above installs again, with those versions listed.

I got it all installed (VB,vagrant, node, nmp, bower) and followed the steps as listed in this post above.

However I am having the same issue! The box is still powered off. Running vagrant up does go through the process (installs the plugins (hostmanager/bond) ansible and all the vb box stuff) and it does give you the message that the box is provisioned and turned on (with no errors shown) ‘the trellis box is ready to use’ BUT going to localhost:3000 or the roots-example-project.test fails.

I can ssh into the box by doing vagrant ssh and can view the files on it no issues there. maybe i am being a bit thick here. Should i be viewing localhost:3000 on the VM? could it be that simple? if so how do i do that? its powered off…

Can anyone shed light on why this is happening. Cannot seem to get off first base and desperately want to get sage working and to stop pulling out the little hair i do have left on my head :frowning:

1 Like